summaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2019-07-06 21:21:34 +0200
committerDaniel Golle <daniel@makrotopia.org>2019-07-10 16:56:16 +0200
commit08e0db3e982e56a380f82b5b58e888f41e1cec9b (patch)
tree1fe4773c875371aebbcb61354ec523cb61a90f20 /target/linux/oxnas
parent7d96c301d6afc9f360c26b404e435e8e03c1e207 (diff)
downloadopenwrt-08e0db3e982e56a380f82b5b58e888f41e1cec9b.tar.gz
openwrt-08e0db3e982e56a380f82b5b58e888f41e1cec9b.tar.bz2
openwrt-08e0db3e982e56a380f82b5b58e888f41e1cec9b.zip
oxnas: convert DEVICE_TITLE to new variables
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'target/linux/oxnas')
-rw-r--r--target/linux/oxnas/image/ox810se.mk4
-rw-r--r--target/linux/oxnas/image/ox820.mk17
2 files changed, 13 insertions, 8 deletions
diff --git a/target/linux/oxnas/image/ox810se.mk b/target/linux/oxnas/image/ox810se.mk
index 52170a26fa..2cb61c5645 100644
--- a/target/linux/oxnas/image/ox810se.mk
+++ b/target/linux/oxnas/image/ox810se.mk
@@ -12,7 +12,9 @@ endef
define Device/wd-mbwe
DEVICE_DTS := ox810se-wd-mbwe
- DEVICE_TITLE := Western Digital My Book World Edition
+ DEVICE_VENDOR := Western Digital
+ DEVICE_MODEL := My Book
+ DEVICE_VARIANT := World Edition
KERNEL := kernel-bin | append-dtb | uImage none
endef
TARGET_DEVICES += wd-mbwe
diff --git a/target/linux/oxnas/image/ox820.mk b/target/linux/oxnas/image/ox820.mk
index de1bfd19fb..0c0301b1ec 100644
--- a/target/linux/oxnas/image/ox820.mk
+++ b/target/linux/oxnas/image/ox820.mk
@@ -39,7 +39,8 @@ define Build/encrypt-3des
endef
define Device/akitio_mycloud
- DEVICE_TITLE := Akition myCloud (mini) / SilverStone DC01
+ DEVICE_VENDOR := Akition
+ DEVICE_MODEL := myCloud mini
SUPPORTED_DEVICES += akitio
DEVICE_PACKAGES := kmod-usb2-oxnas kmod-ata-oxnas-sata kmod-usb-ledtrig-usbport \
kmod-i2c-gpio kmod-rtc-ds1307
@@ -47,23 +48,25 @@ endef
TARGET_DEVICES += akitio_mycloud
define Device/cloudengines_pogoplugpro
- DEVICE_TITLE := Cloud Engines PogoPlug Pro (with mPCIe)
+ DEVICE_VENDOR := Cloud Engines
+ DEVICE_MODEL := PogoPlug Pro (with mPCIe)
SUPPORTED_DEVICES += pogoplug-pro
DEVICE_PACKAGES := kmod-usb2-oxnas kmod-usb-ledtrig-usbport kmod-rt2800-pci wpad-basic
endef
TARGET_DEVICES += cloudengines_pogoplugpro
define Device/cloudengines_pogoplug-series-3
- DEVICE_TITLE := Cloud Engines PogoPlug Series V3 (without mPCIe)
+ DEVICE_VENDOR := Cloud Engines
+ DEVICE_MODEL := PogoPlug Series V3 (without mPCIe)
SUPPORTED_DEVICES += cloudengines,pogoplugv3 pogoplug-v3
DEVICE_PACKAGES := kmod-usb2-oxnas kmod-usb-ledtrig-usbport
endef
TARGET_DEVICES += cloudengines_pogoplug-series-3
define Device/shuttle_kd20
- DEVICE_TITLE := Shuttle KD20
+ DEVICE_VENDOR := Shuttle
+ DEVICE_MODEL := KD20
SUPPORTED_DEVICES += kd20
- KERNEL := kernel-bin | append-dtb | uImage none
KERNEL_INITRAMFS_PREFIX = $$(IMAGE_PREFIX)-factory
KERNEL_INITRAMFS_SUFFIX := .tar.gz
KERNEL_INITRAMFS = kernel-bin | append-dtb | uImage none | omninas-factory | encrypt-3des sohmuntitnlaes
@@ -75,9 +78,9 @@ endef
TARGET_DEVICES += shuttle_kd20
define Device/mitrastar_stg-212
- DEVICE_TITLE := MitraStar STG-212
+ DEVICE_VENDOR := MitraStar
+ DEVICE_MODEL := STG-212
SUPPORTED_DEVICES += stg212
- KERNEL := kernel-bin | append-dtb | uImage none
DEVICE_PACKAGES := kmod-usb2-oxnas kmod-ata-oxnas-sata kmod-fs-ext4 kmod-fs-xfs \
kmod-usb-ledtrig-usbport
endef