summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/files/drivers/net/ethernet/ralink/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-11-06 09:31:03 +0000
committerJohn Crispin <john@openwrt.org>2014-11-06 09:31:03 +0000
commitd524fe46fdf7eeb2f784bdb790eb211c8d221fc5 (patch)
tree681aa258456c0b3547ca6756a50f65254bf7f6c6 /target/linux/ramips/files/drivers/net/ethernet/ralink/Makefile
parent74e94df8eb23205df8bc49c6512f0d1d6f0078f9 (diff)
downloadopenwrt-d524fe46fdf7eeb2f784bdb790eb211c8d221fc5.tar.gz
openwrt-d524fe46fdf7eeb2f784bdb790eb211c8d221fc5.tar.bz2
openwrt-d524fe46fdf7eeb2f784bdb790eb211c8d221fc5.zip
ralink: move ethernet driver to files/
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 43194
Diffstat (limited to 'target/linux/ramips/files/drivers/net/ethernet/ralink/Makefile')
-rw-r--r--target/linux/ramips/files/drivers/net/ethernet/ralink/Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/ramips/files/drivers/net/ethernet/ralink/Makefile b/target/linux/ramips/files/drivers/net/ethernet/ralink/Makefile
new file mode 100644
index 0000000000..01884a7836
--- /dev/null
+++ b/target/linux/ramips/files/drivers/net/ethernet/ralink/Makefile
@@ -0,0 +1,18 @@
+#
+# Makefile for the Ralink SoCs built-in ethernet macs
+#
+
+ralink-eth-y += ralink_soc_eth.o ralink_ethtool.o
+
+ralink-eth-$(CONFIG_NET_RALINK_MDIO) += mdio.o
+ralink-eth-$(CONFIG_NET_RALINK_MDIO_RT2880) += mdio_rt2880.o
+
+ralink-eth-$(CONFIG_NET_RALINK_ESW_RT3052) += esw_rt3052.o
+ralink-eth-$(CONFIG_NET_RALINK_GSW_MT7620) += gsw_mt7620a.o mt7530.o
+
+ralink-eth-$(CONFIG_SOC_RT288X) += soc_rt2880.o
+ralink-eth-$(CONFIG_SOC_RT305X) += soc_rt305x.o
+ralink-eth-$(CONFIG_SOC_RT3883) += soc_rt3883.o
+ralink-eth-$(CONFIG_SOC_MT7620) += soc_mt7620.o
+
+obj-$(CONFIG_NET_RALINK) += ralink-eth.o