summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2019-07-11 17:15:48 +0200
committerDavid Bauer <mail@david-bauer.net>2019-07-11 21:32:39 +0200
commit14e0e4f138e35c3e2a15cc3a836c939547ee053b (patch)
tree6cf0e9eb7b2a4f3f5c8ae0452aff83c42ceb3262 /target/linux/ramips/image/mt7621.mk
parentc52ca08d40086c6f5aff168178dc1948eae19b4a (diff)
downloadopenwrt-14e0e4f138e35c3e2a15cc3a836c939547ee053b.tar.gz
openwrt-14e0e4f138e35c3e2a15cc3a836c939547ee053b.tar.bz2
openwrt-14e0e4f138e35c3e2a15cc3a836c939547ee053b.zip
ramips: add support for ASUS RT-AC57U
SoC: MediaTek MT7621AT RAM: 128M (Winbond W631GG6KB-15) FLASH: 16MB (Spansion S25FL128SA) WiFi: MediaTek MT7603EN bgn 2SS WiFi: MediaTek MT7612EN nac 2SS BTN: Reset - WPS LED: - Power - LAN {1-4} - WAN - WiFi 2.4 GHz - WiFi 5 GHz - USB UART: UART is present next to the Power LED. TX - RX - GND - 3V3 / 57600-8N1 3V3 is the nearest one to the Power LED. Installation ------------ Via TFTP: 1. Set your computers IP-Address to 192.168.1.75. 2. Power up the Router with the Reset button pressed. 3. Release the Reset button after 5 seconds. 4. Upload OpenWRT sysupgrade image via TFTP: > tftp -4 -v -m binary 192.168.1.1 -c put <IMAGE> Via SSH: Note: User/password for SSH is identical with the one used in the Web-interface. 1. Complete the initial setup wizard. 2. Activate SSH under "Administration" -> "System". 3. Transfer the OpenWrt sysupgrade image via scp: > scp owrt.bin admin@192.168.1.1:/tmp 4. Connect via SSH to the router. > ssh admin@192.168.1.1 5. Write the OpenWrt image to flash. > mtd-write -i /tmp/owrt.bin -d linux 6. Reboot the router > reboot Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 1cd9092b14..e2928c80ce 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -106,6 +106,15 @@ define Device/asiarf_ap7621-001
endef
TARGET_DEVICES += asiarf_ap7621-001
+define Device/asus_rt-ac57u
+ MTK_SOC := mt7621
+ DEVICE_VENDOR := ASUS
+ DEVICE_MODEL := RT-AC57U
+ IMAGE_SIZE := 16064k
+ DEVICE_PACKAGES := kmod-mt7603 kmod-mt76x2 kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic
+endef
+TARGET_DEVICES += asus_rt-ac57u
+
define Device/buffalo_wsr-1166dhp
MTK_SOC := mt7621
IMAGE/sysupgrade.bin := trx | pad-rootfs | append-metadata