summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips
diff options
context:
space:
mode:
authorAlan Luck <luckyhome2008@gmail.com>2023-11-08 09:10:35 +1100
committerHauke Mehrtens <hauke@hauke-m.de>2023-11-12 15:03:05 +0100
commit4c0dc68f466588bb2ef60b29a4d8052b34112ca6 (patch)
tree33a3cf797b20908a84853933297a1ca84f64b9f2 /target/linux/ramips
parentf74f5b29948aa9303bf94045cf938cee49897944 (diff)
downloadopenwrt-4c0dc68f466588bb2ef60b29a4d8052b34112ca6.tar.gz
openwrt-4c0dc68f466588bb2ef60b29a4d8052b34112ca6.tar.bz2
openwrt-4c0dc68f466588bb2ef60b29a4d8052b34112ca6.zip
ramips: add encrypted SGE factory image for D-Link devices
creates SGE encrypted factory images to use via the D-Link web interface rename the old factory unencrypted images to recovery for use in the recovery console when recovery is needed DIR-1935-A1 , DIR-853-A1 , DIR-853-A3 , DIR-867-A1 , DIR-878-A1 and DIR-882-A1 Signed-off-by: Alan Luck <luckyhome2008@gmail.com>
Diffstat (limited to 'target/linux/ramips')
-rw-r--r--target/linux/ramips/image/mt7621.mk13
1 files changed, 7 insertions, 6 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index b9c94342b0..16794c4f50 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -684,10 +684,9 @@ define Device/dlink_dir-8xx-a1
DEVICE_VENDOR := D-Link
DEVICE_PACKAGES := kmod-mt7615-firmware -uboot-envtools
KERNEL := $$(KERNEL) | uimage-sgehdr
- IMAGES += factory.bin
- IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | \
- check-size | append-metadata
- IMAGE/factory.bin := append-kernel | append-rootfs | check-size
+ IMAGES += recovery.bin factory.bin
+ IMAGE/recovery.bin := append-kernel | append-rootfs | check-size
+ IMAGE/factory.bin := $$(IMAGE/recovery.bin) | dlink-sge-image $$$$(DEVICE_MODEL)
endef
define Device/dlink_dir-8xx-r1
@@ -707,8 +706,8 @@ define Device/dlink_dir-xx60-a1
DEVICE_PACKAGES := kmod-mt7615-firmware kmod-usb3 \
kmod-usb-ledtrig-usbport -uboot-envtools
KERNEL := $$(KERNEL) | uimage-sgehdr
- IMAGES += factory.bin
- IMAGE/factory.bin := append-kernel | pad-to $$(KERNEL_SIZE) | append-ubi | \
+ IMAGES += recovery.bin
+ IMAGE/recovery.bin := append-kernel | pad-to $$(KERNEL_SIZE) | append-ubi | \
check-size
endef
@@ -760,6 +759,8 @@ define Device/dlink_dir-853-a3
$(Device/dlink_dir-xx60-a1)
DEVICE_MODEL := DIR-853
DEVICE_VARIANT := A3
+ IMAGES += factory.bin
+ IMAGE/factory.bin := $$(IMAGE/recovery.bin) | dlink-sge-image $$(DEVICE_MODEL)
endef
TARGET_DEVICES += dlink_dir-853-a3