summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips
diff options
context:
space:
mode:
authorINAGAKI Hiroshi <musashino.open@gmail.com>2024-03-25 21:39:30 +0900
committerHauke Mehrtens <hauke@hauke-m.de>2024-05-11 19:33:28 +0200
commit61e8728d86d7c11e1a5adab4bd37dae6b3b6cf2b (patch)
tree2f41fe764cdc8f5e935eb9b3ebfdf012b1b80578 /target/linux/ramips
parent927a77ecffd791aa096faff609d6897f99673603 (diff)
downloadopenwrt-61e8728d86d7c11e1a5adab4bd37dae6b3b6cf2b.tar.gz
openwrt-61e8728d86d7c11e1a5adab4bd37dae6b3b6cf2b.tar.bz2
openwrt-61e8728d86d7c11e1a5adab4bd37dae6b3b6cf2b.zip
ramips: add support for ELECOM WMC-S1267GS2
ELECOM WMC-S1267GS2 is a 2.4/5 GHz band 11ac (Wi-Fi 5) mesh extender, based on MT7621A. This device has almost the same hardware as WMC-M1267GST2. Specification: - SoC : MediaTek MT7621A - RAM : DDR3 256 MiB (Nanya NT5CC128M16JR-EK) - Flash : SPI-NOR 32 MiB (Winbond W25Q256JVFIQ) - WLAN : 2.4/5 GHz 2T2R (MediaTek MT7615D) - Ethernet : 10/100/1000 Mbps x4 - switch : MediaTek MT7530 (SoC) - LEDs/Keys : 6x/6x - UART : through-hole on PCB ("J4") - arrangement: 3.3V, GND, TX, RX from tri-angle marking - settings : 57600n8 - Power : 12 VDC, 1 A Flash instruction using factory image: 1. Boot WMC-S1267GS2 normally 2. Set IP address of the computer to 192.168.2.x 3. Access to "http://192.168.2.1/" and open firmware update page ("ファームウェア更新") 4. Select the OpenWrt factory image and click apply ("適用") button 5. Wait ~120 seconds to complete flashing MAC addresses: LAN : 04:AB:18:xx:xx:9E (Factory, 0xFFF4 (hex)) 2.4 GHz: 04:AB:18:xx:xx:9F 5 GHz : 04:AB:18:xx:xx:A0 (Factory, 0x4 (hex)) Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com>
Diffstat (limited to 'target/linux/ramips')
-rw-r--r--target/linux/ramips/dts/mt7621_elecom_wmc-s1267gs2.dts82
-rw-r--r--target/linux/ramips/image/mt7621.mk8
-rw-r--r--target/linux/ramips/mt7621/base-files/etc/board.d/02_network11
3 files changed, 96 insertions, 5 deletions
diff --git a/target/linux/ramips/dts/mt7621_elecom_wmc-s1267gs2.dts b/target/linux/ramips/dts/mt7621_elecom_wmc-s1267gs2.dts
new file mode 100644
index 0000000000..942fa1cb46
--- /dev/null
+++ b/target/linux/ramips/dts/mt7621_elecom_wmc-s1267gs2.dts
@@ -0,0 +1,82 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7621_elecom_wrc-gs-1pci.dtsi"
+
+/ {
+ compatible = "elecom,wmc-s1267gs2", "mediatek,mt7621-soc";
+ model = "ELECOM WMC-S1267GS2";
+
+ aliases {
+ /*
+ * A MAC address printed to the label is an address of
+ * 5 GHz band on stock firmware, but there is no
+ * per-band MAC address support on Linux Kernel and that
+ * address is not assigned to any wlan devices now.
+ */
+ /delete-property/ label-mac-device;
+ };
+};
+
+&gmac0 {
+ nvmem-cells = <&macaddr_factory_fff4>;
+ nvmem-cell-names = "mac-address";
+};
+
+&gmac1 {
+ status = "disabled";
+};
+
+&partitions {
+ partition@50000 {
+ compatible = "denx,uimage";
+ label = "firmware";
+ reg = <0x50000 0x1800000>;
+ };
+
+ partition@1850000 {
+ label = "tm_pattern";
+ reg = <0x1850000 0x400000>;
+ read-only;
+ };
+
+ partition@1c50000 {
+ label = "tm_key";
+ reg = <0x1c50000 0x100000>;
+ read-only;
+ };
+
+ partition@1d50000 {
+ label = "nvram";
+ reg = <0x1d50000 0xb0000>;
+ read-only;
+ };
+
+ partition@1e00000 {
+ label = "user_data";
+ reg = <0x1e00000 0x200000>;
+ read-only;
+ };
+};
+
+&wifi {
+ nvmem-cells = <&macaddr_factory_4 (-1)>;
+ nvmem-cell-names = "mac-address";
+};
+
+&factory {
+ nvmem-layout {
+ compatible = "fixed-layout";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ macaddr_factory_4: macaddr@4 {
+ compatible = "mac-base";
+ reg = <0x4 0x6>;
+ #nvmem-cell-cells = <1>;
+ };
+
+ macaddr_factory_fff4: macaddr@fff4 {
+ reg = <0xfff4 0x6>;
+ };
+ };
+};
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index a0b6fe9e5f..33fcc805d9 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -998,6 +998,14 @@ define Device/elecom_wmc-m1267gst2
endef
TARGET_DEVICES += elecom_wmc-m1267gst2
+define Device/elecom_wmc-s1267gs2
+ $(Device/elecom_wrc-gs)
+ IMAGE_SIZE := 24576k
+ DEVICE_MODEL := WMC-S1267GS2
+ ELECOM_HWNAME := WMC-DLGST2
+endef
+TARGET_DEVICES += elecom_wmc-s1267gs2
+
define Device/elecom_wrc-1167ghbk2-s
$(Device/dsa-migration)
IMAGE_SIZE := 15488k
diff --git a/target/linux/ramips/mt7621/base-files/etc/board.d/02_network b/target/linux/ramips/mt7621/base-files/etc/board.d/02_network
index d932313cf1..2ed8c38732 100644
--- a/target/linux/ramips/mt7621/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/mt7621/base-files/etc/board.d/02_network
@@ -102,17 +102,18 @@ ramips_setup_interfaces()
dlink,covr-x1860-a1)
ucidef_set_interfaces_lan_wan "ethernet" "internet"
;;
+ elecom,wmc-s1267gs2|\
+ linksys,re6500|\
+ netgear,wac104|\
+ zyxel,lte3301-plus)
+ ucidef_set_interface_lan "lan1 lan2 lan3 lan4"
+ ;;
gnubee,gb-pc1)
ucidef_set_interface_lan "ethblack ethblue"
;;
gnubee,gb-pc2)
ucidef_set_interface_lan "ethblack ethblue ethyellow"
;;
- linksys,re6500|\
- netgear,wac104|\
- zyxel,lte3301-plus)
- ucidef_set_interface_lan "lan1 lan2 lan3 lan4"
- ;;
mikrotik,routerboard-750gr3)
ucidef_set_interfaces_lan_wan "lan2 lan3 lan4 lan5" "wan"
;;