summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips
diff options
context:
space:
mode:
authorMax Qian <public@maxqia.com>2023-09-14 21:54:30 -0700
committerMax Qian <public@maxqia.com>2023-09-17 13:52:55 -0700
commit794349a28a7b9036b54e13487a96120609db924e (patch)
treefbd224d45dc0d9d73368494c299deac330a7edb3 /target/linux/ramips
parent98bad1b4fc0d1a42b20eb1d3518f59aa7bb0b2d8 (diff)
downloadopenwrt-794349a28a7b9036b54e13487a96120609db924e.tar.gz
openwrt-794349a28a7b9036b54e13487a96120609db924e.tar.bz2
openwrt-794349a28a7b9036b54e13487a96120609db924e.zip
ramips: RT1800: fix invalid octal number error
This commit removes the padded zeros in the date formatting. The padded zeros from the date command causes the numbers to be interpreted as an octal number by printf. Months, days, and years with the number 08 or 09 raise an error in printf as an "invalid octal number" and get interpreted as a zero. Signed-off-by: Max Qian <public@maxqia.com>
Diffstat (limited to 'target/linux/ramips')
-rw-r--r--target/linux/ramips/image/mt7621.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index abcdc08ade..065a61de28 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -119,7 +119,7 @@ define Build/belkin-header
( \
type_fw_date=$$(printf "01%02x%02x%02x" \
- $$(date -d "@$(SOURCE_DATE_EPOCH)" "+%y %m %d")); \
+ $$(date -d "@$(SOURCE_DATE_EPOCH)" "+%-y %-m %-d")); \
hw_fw_ver=$$(printf "%02x%02x%02x%02x" \
$(hw_ver) $$(echo $(fw_ver) | cut -d. -f-3 | tr . ' ')); \
fw_len_crc=$$(gzip -c $@ | tail -c 8 | od -An -tx8 | tr -d ' \n'); \