summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips
diff options
context:
space:
mode:
authorSijia Huang <engineer31@win-star.com>2023-08-26 00:38:01 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2023-09-24 12:36:52 +0200
commitab12a01cd78772b4cfc82db7d0002c05dc0f97b5 (patch)
treeadf468b09e97afa6368d310fb5bfb18abd721e05 /target/linux/ramips
parente3559fb4453c99c25f6234beda69e1e8a95e663f (diff)
downloadopenwrt-ab12a01cd78772b4cfc82db7d0002c05dc0f97b5.tar.gz
openwrt-ab12a01cd78772b4cfc82db7d0002c05dc0f97b5.tar.bz2
openwrt-ab12a01cd78772b4cfc82db7d0002c05dc0f97b5.zip
ramips: add support for WAVLINK WL-WN573HX1
Hardware -------- Specifications: - Device: WAVLINK WL-WN573HX1 Outdoor AP - SoC: MT7621AT - Flash: 16MB - RAM: 256MB - Switch:1 LAN (10/100/1000 Mbps) - WiFi: MT7905 2x2 2.4G + MT7975 2x2 5G - LEDs: 1x STATUS (blue, configurable) 1x LAN (green) Product link: https://www.wavlink.com/en_us/product/WL-WN573HX1.html Signed-off-by: Sijia Huang <engineer31@win-star.com>
Diffstat (limited to 'target/linux/ramips')
-rwxr-xr-xtarget/linux/ramips/dts/mt7621_wavlink_wl-wn573hx1.dts133
-rw-r--r--target/linux/ramips/image/mt7621.mk14
-rw-r--r--target/linux/ramips/mt7621/base-files/etc/board.d/02_network1
3 files changed, 148 insertions, 0 deletions
diff --git a/target/linux/ramips/dts/mt7621_wavlink_wl-wn573hx1.dts b/target/linux/ramips/dts/mt7621_wavlink_wl-wn573hx1.dts
new file mode 100755
index 0000000000..d8a94c85b9
--- /dev/null
+++ b/target/linux/ramips/dts/mt7621_wavlink_wl-wn573hx1.dts
@@ -0,0 +1,133 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7621.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+ compatible = "wavlink,wl-wn573hx1", "mediatek,mt7621-soc";
+ model = "WAVLINK WL-WN573HX1";
+
+ aliases {
+ led-boot = &led_status_blue;
+ led-failsafe = &led_status_blue;
+ led-running = &led_status_blue;
+ led-upgrade = &led_status_blue;
+ label-mac-device = &gmac0;
+ };
+
+ chosen {
+ bootargs = "console=ttyS0,115200";
+ };
+
+ keys {
+ compatible = "gpio-keys";
+
+ reset {
+ label = "reset";
+ gpios = <&gpio 13 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_RESTART>;
+ };
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ led_status_blue:status_led {
+ label = "blue:status_led";
+ gpios = <&gpio 16 GPIO_ACTIVE_LOW>;
+ };
+
+ };
+};
+
+&gmac0 {
+ nvmem-cells = <&macaddr_factory_3fff4>;
+ nvmem-cell-names = "mac-address";
+};
+
+&mdio {
+ ethphy4: ethernet-phy@4 {
+ reg = <4>;
+ };
+};
+
+&pcie {
+ status = "okay";
+};
+
+&pcie1 {
+ wifi@0,0 {
+ compatible = "mediatek,mt76";
+ reg = <0x0000 0 0 0 0>;
+ mediatek,mtd-eeprom = <&factory 0x0>;
+ };
+};
+
+&spi0 {
+ status = "okay";
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <14000000>;
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x00000 0x30000>;
+ };
+
+ partition@30000 {
+ label = "config";
+ reg = <0x30000 0x10000>;
+ };
+
+ factory:partition@50000 {
+ label = "factory";
+ reg = <0x50000 0x40000>;
+ };
+
+ partition@90000 {
+ compatible = "denx,uimage";
+ label = "firmware";
+ reg = <0x90000 0xf70000>;
+ };
+ };
+ };
+};
+
+&gmac0 {
+ nvmem-cells = <&macaddr_factory_3fff4>;
+ nvmem-cell-names = "mac-address";
+};
+
+&mdio {
+ ethphy4: ethernet-phy@4 {
+ reg = <4>;
+ };
+};
+
+&switch0 {
+ ports {
+ port@3 {
+ status = "okay";
+ label = "lan";
+ };
+ };
+};
+
+
+&factory {
+ compatible = "nvmem-cells";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ macaddr_factory_3fff4: macaddr@3fff4 {
+ reg = <0x3fff4 0x6>;
+ };
+
+};
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 065a61de28..0710564fa5 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -2546,6 +2546,20 @@ define Device/wavlink_ws-wn572hp3-4g
endef
TARGET_DEVICES += wavlink_ws-wn572hp3-4g
+
+define Device/wavlink_wl-wn573hx1
+ $(Device/uimage-lzma-loader)
+ IMAGE_SIZE := 15808k
+ DEVICE_VENDOR := Wavlink
+ DEVICE_MODEL := WL-WN573HX1
+ DEVICE_PACKAGES := kmod-mt7915-firmware -uboot-envtools
+ IMAGES += factory.bin
+ IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | \
+ check-size | append-metadata
+ IMAGE/factory.bin := append-kernel | append-rootfs | pad-rootfs | check-size
+endef
+TARGET_DEVICES += wavlink_wl-wn573hx1
+
define Device/wevo_11acnas
$(Device/dsa-migration)
$(Device/uimage-lzma-loader)
diff --git a/target/linux/ramips/mt7621/base-files/etc/board.d/02_network b/target/linux/ramips/mt7621/base-files/etc/board.d/02_network
index a162cb9d1d..e0b229c7ee 100644
--- a/target/linux/ramips/mt7621/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/mt7621/base-files/etc/board.d/02_network
@@ -55,6 +55,7 @@ ramips_setup_interfaces()
ubnt,unifi-flexhd|\
ubnt,unifi-nanohd|\
yuncore,fap690|\
+ wavlink,wl-wn573hx1|\
zyxel,nwa50ax|\
zyxel,nwa55axe)
ucidef_set_interface_lan "lan"