summaryrefslogtreecommitdiffstats
path: root/target/linux/realtek
diff options
context:
space:
mode:
authorKevin Jilissen <info@kevinjilissen.nl>2023-10-08 17:21:23 +0200
committerSander Vanheule <sander@svanheule.net>2023-10-09 19:29:45 +0200
commitf4ee08677cdeefba7cfda40a830b6b747c6ea36e (patch)
tree06a05d74c46cdeda993df390fb0b42e320d3a648 /target/linux/realtek
parent987c96e88927094ff61e83870f872f0560d8e5c1 (diff)
downloadopenwrt-f4ee08677cdeefba7cfda40a830b6b747c6ea36e.tar.gz
openwrt-f4ee08677cdeefba7cfda40a830b6b747c6ea36e.tar.bz2
openwrt-f4ee08677cdeefba7cfda40a830b6b747c6ea36e.zip
realtek: add support for HPE 1920-8g-poe+ (65W)
Hardware information: --------------------- - RTL8380 SoC - 8 Gigabit RJ45 PoE ports (built-in RTL8218B) - 2 SFP ports (built-in SerDes) - RJ45 RS232 port on front panel - 32 MiB NOR Flash - 128 MiB DDR3 DRAM - PT7A7514 watchdog - PoE chip - Fanless Known issues: --------------------- - PoE LEDs are uncontrolled. (Manual taken from f2f09bc) Booting initramfs image: ------------------------ - Prepare a FTP or TFTP server serving the OpenWrt initramfs image and connect the server to a switch port. - Connect to the console port of the device and enter the extended boot menu by typing Ctrl+B when prompted. - Choose the menu option "<3> Enter Ethernet SubMenu". - Set network parameters via the option "<5> Modify Ethernet Parameter". Enter the FTP/TFTP filename as "Load File Name" ("Target File Name" can be left blank, it is not required for booting from RAM). Note that the configuration is saved on flash, so it only needs to be done once. - Select "<1> Download Application Program To SDRAM And Run". Initial installation: --------------------- - Boot an initramfs image as described above, then use sysupgrade to install OpenWrt permanently. After initial installation, the bootloader needs to be configured to load the correct image file - Enter the extended boot menu again and choose "<4> File Control", then select "<2> Set Application File type". - Enter the number of the file "openwrt-kernel.bin" (should be 1), and use the option "<1> +Main" to select it as boot image. - Choose "<0> Exit To Main Menu" and then "<1> Boot System". NOTE: The bootloader on these devices can only boot from the VFS filesystem which normally spans most of the flash. With OpenWrt, only the first part of the firmware partition contains a valid filesystem, the rest is used for rootfs. As the bootloader does not know about this, you must not do any file operations in the bootloader, as this may corrupt the OpenWrt installation (selecting the boot image is an exception, as it only stores a flag in the bootloader data, but doesn't write to the filesystem). Example PoE config file (/etc/config/poe): --------------------- config global option budget '65' config port option enable '1' option id '1' option name 'lan8' option poe_plus '1' option priority '2' config port option enable '1' option id '2' option name 'lan7' option poe_plus '1' option priority '2' config port option enable '1' option id '3' option name 'lan6' option poe_plus '1' option priority '2' config port option enable '1' option id '4' option name 'lan5' option poe_plus '1' option priority '2' config port option enable '1' option id '5' option name 'lan4' option poe_plus '1' option priority '2' config port option enable '1' option id '6' option name 'lan3' option poe_plus '1' option priority '2' config port option enable '1' option id '7' option name 'lan2' option poe_plus '1' option priority '2' config port option enable '1' option id '8' option name 'lan1' option poe_plus '1' option priority '2' Signed-off-by: Kevin Jilissen <info@kevinjilissen.nl>
Diffstat (limited to 'target/linux/realtek')
-rw-r--r--target/linux/realtek/base-files/etc/board.d/02_network4
-rw-r--r--target/linux/realtek/dts-5.15/rtl8380_hpe_1920-8g-poe-65w.dts12
-rw-r--r--target/linux/realtek/image/rtl838x.mk9
3 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/realtek/base-files/etc/board.d/02_network b/target/linux/realtek/base-files/etc/board.d/02_network
index 84d3e68e48..45bc2196d4 100644
--- a/target/linux/realtek/base-files/etc/board.d/02_network
+++ b/target/linux/realtek/base-files/etc/board.d/02_network
@@ -31,6 +31,7 @@ lan_mac_end=""
label_mac=""
case $board in
hpe,1920-8g|\
+hpe,1920-8g-poe-65w|\
hpe,1920-8g-poe-180w|\
hpe,1920-16g|\
hpe,1920-24g)
@@ -67,6 +68,9 @@ done
[ -n "$label_mac" ] && ucidef_set_label_macaddr $label_mac
case $board in
+hpe,1920-8g-poe-65w)
+ ucidef_set_poe 65 "$lan_list_rev" "lan9 lan10"
+ ;;
hpe,1920-8g-poe-180w)
ucidef_set_poe 180 "$lan_list_rev" "lan9 lan10"
;;
diff --git a/target/linux/realtek/dts-5.15/rtl8380_hpe_1920-8g-poe-65w.dts b/target/linux/realtek/dts-5.15/rtl8380_hpe_1920-8g-poe-65w.dts
new file mode 100644
index 0000000000..341f535e93
--- /dev/null
+++ b/target/linux/realtek/dts-5.15/rtl8380_hpe_1920-8g-poe-65w.dts
@@ -0,0 +1,12 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "rtl8380_hpe_1920-8g.dtsi"
+
+/ {
+ compatible = "hpe,1920-8g-poe-65w", "realtek,rtl838x-soc";
+ model = "HPE 1920-8G-PoE+ 65W (JG921A)";
+};
+
+&uart1 {
+ status = "okay";
+};
diff --git a/target/linux/realtek/image/rtl838x.mk b/target/linux/realtek/image/rtl838x.mk
index c0b9c70bb6..09b4f3ebb0 100644
--- a/target/linux/realtek/image/rtl838x.mk
+++ b/target/linux/realtek/image/rtl838x.mk
@@ -99,6 +99,15 @@ define Device/hpe_1920-8g
endef
TARGET_DEVICES += hpe_1920-8g
+define Device/hpe_1920-8g-poe-65w
+ $(Device/hpe_1920)
+ SOC := rtl8380
+ DEVICE_MODEL := 1920-8G-PoE+ 65W (JG921A)
+ DEVICE_PACKAGES += realtek-poe
+ H3C_DEVICE_ID := 0x00010024
+endef
+TARGET_DEVICES += hpe_1920-8g-poe-65w
+
define Device/hpe_1920-8g-poe-180w
$(Device/hpe_1920)
SOC := rtl8380