summaryrefslogtreecommitdiffstats
path: root/target/linux/rockchip/image/armv8.mk
diff options
context:
space:
mode:
authorMarius Durbaca <mariusd84@gmail.com>2024-02-28 09:39:44 +0000
committerNick Hainke <vincent@systemli.org>2024-03-23 07:55:43 +0100
commitf7c732bf9ed9bd09646a528681256fb7b0d80bfc (patch)
tree5b3ab5b0a7555deb8df1221a8d7676efb5094298 /target/linux/rockchip/image/armv8.mk
parentce5661e455f7bb87c028ac989c6d05dbc174877b (diff)
downloadopenwrt-f7c732bf9ed9bd09646a528681256fb7b0d80bfc.tar.gz
openwrt-f7c732bf9ed9bd09646a528681256fb7b0d80bfc.tar.bz2
openwrt-f7c732bf9ed9bd09646a528681256fb7b0d80bfc.zip
rockchip: add Radxa E25 board support
Radxa E25 is a network application carrier board for the Radxa CM3 Industrial (CM3I) SoM, which is based on the Rockchip RK3568 SoC. It has the following features: - MicroSD card socket, on board eMMC flash - 2x 2.5GbE Realtek RTL8125B Ethernet transceiver - 1x USB Type-C port (Power and Serial console) - 1x USB 3.0 OTG port - mini PCIe socket (USB or PCIe) - ngff PCIe socket (USB or SATA) - 1x User LED and 16x RGB LEDs - 26-pin expansion header Installation: Uncompress the OpenWrt sysupgrade and write it to a micro SD card or internal eMMC using dd. Signed-off-by: Marius Durbaca <mariusd84@gmail.com>
Diffstat (limited to 'target/linux/rockchip/image/armv8.mk')
-rw-r--r--target/linux/rockchip/image/armv8.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/rockchip/image/armv8.mk b/target/linux/rockchip/image/armv8.mk
index 251a9c17db..d457058282 100644
--- a/target/linux/rockchip/image/armv8.mk
+++ b/target/linux/rockchip/image/armv8.mk
@@ -104,6 +104,16 @@ define Device/radxa_cm3-io
endef
TARGET_DEVICES += radxa_cm3-io
+define Device/radxa_e25
+ DEVICE_VENDOR := Radxa
+ DEVICE_MODEL := E25
+ SOC := rk3568
+ DEVICE_DTS := rockchip/rk3568-radxa-e25
+ UBOOT_DEVICE_NAME := radxa-e25-rk3568
+ DEVICE_PACKAGES := kmod-r8169 kmod-ata-ahci-platform
+endef
+TARGET_DEVICES += radxa_e25
+
define Device/radxa_rock-pi-4a
DEVICE_VENDOR := Radxa
DEVICE_MODEL := ROCK Pi 4A