summaryrefslogtreecommitdiffstats
path: root/target/linux/rockchip
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2020-07-13 17:44:07 +0200
committerDavid Bauer <mail@david-bauer.net>2020-07-13 17:50:35 +0200
commit875a04478c177808e86a6a615f0ae0cfe541f2c2 (patch)
tree43df3e58e1a3d9fb63633d419cfe6db2fe137737 /target/linux/rockchip
parent79fd87ef9d12c178649648744429ff9ba7a7f0c7 (diff)
downloadopenwrt-875a04478c177808e86a6a615f0ae0cfe541f2c2.tar.gz
openwrt-875a04478c177808e86a6a615f0ae0cfe541f2c2.tar.bz2
openwrt-875a04478c177808e86a6a615f0ae0cfe541f2c2.zip
rockchip: use downstream GPIO button implementation
Use the OpenWrt netlink GPIO button implementation to forward button presses to procd. This is necessary to make failsafe-mode access using a button possible. Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/rockchip')
-rw-r--r--target/linux/rockchip/Makefile2
-rw-r--r--target/linux/rockchip/armv8/config-5.41
2 files changed, 1 insertions, 2 deletions
diff --git a/target/linux/rockchip/Makefile b/target/linux/rockchip/Makefile
index 41f0560bac..8daaad34a7 100644
--- a/target/linux/rockchip/Makefile
+++ b/target/linux/rockchip/Makefile
@@ -17,7 +17,7 @@ endef
include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += uboot-envtools partx-utils e2fsprogs mkf2fs
+DEFAULT_PACKAGES += uboot-envtools partx-utils e2fsprogs mkf2fs kmod-gpio-button-hotplug
KERNELNAME:=Image dtbs
diff --git a/target/linux/rockchip/armv8/config-5.4 b/target/linux/rockchip/armv8/config-5.4
index 48b05b432b..2d2342e34f 100644
--- a/target/linux/rockchip/armv8/config-5.4
+++ b/target/linux/rockchip/armv8/config-5.4
@@ -221,7 +221,6 @@ CONFIG_KALLSYMS=y
CONFIG_KEXEC_CORE=y
CONFIG_KEXEC_FILE=y
# CONFIG_KEXEC_SIG is not set
-CONFIG_KEYBOARD_GPIO=y
CONFIG_KSM=y
# CONFIG_LEDS_BRIGHTNESS_HW_CHANGED is not set
CONFIG_LEDS_GPIO=y