summaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi/image/cortexa8.mk
diff options
context:
space:
mode:
authorChukun Pan <amadeus@jmu.edu.cn>2022-10-10 23:08:27 +0800
committerHauke Mehrtens <hauke@hauke-m.de>2022-12-17 20:55:47 +0100
commit53123b93b0a14deb43274c44ea473ea9b360acf3 (patch)
treeb447af7be8c49b9e3925948c1b0fe18fb1f2391e /target/linux/sunxi/image/cortexa8.mk
parent7bcf6b54fc819c26fc2cea32c464e87614cc2d26 (diff)
downloadopenwrt-53123b93b0a14deb43274c44ea473ea9b360acf3.tar.gz
openwrt-53123b93b0a14deb43274c44ea473ea9b360acf3.tar.bz2
openwrt-53123b93b0a14deb43274c44ea473ea9b360acf3.zip
sunxi: fix board_name for MarsBoard A10
The compatible in the device tree is "haoyu,a10-marsboard", modify the board_name to keep it consistent. Signed-off-by: Chukun Pan <amadeus@jmu.edu.cn>
Diffstat (limited to 'target/linux/sunxi/image/cortexa8.mk')
-rw-r--r--target/linux/sunxi/image/cortexa8.mk19
1 files changed, 10 insertions, 9 deletions
diff --git a/target/linux/sunxi/image/cortexa8.mk b/target/linux/sunxi/image/cortexa8.mk
index 7f50659bdd..eafc2187e8 100644
--- a/target/linux/sunxi/image/cortexa8.mk
+++ b/target/linux/sunxi/image/cortexa8.mk
@@ -11,6 +11,16 @@ define Device/cubietech_a10-cubieboard
endef
TARGET_DEVICES += cubietech_a10-cubieboard
+define Device/haoyu_a10-marsboard
+ DEVICE_VENDOR := HAOYU Electronics
+ DEVICE_MODEL := MarsBoard A10
+ DEVICE_PACKAGES:=kmod-ata-core kmod-ata-sunxi kmod-sun4i-emac \
+ kmod-rtc-sunxi kmod-sound-core kmod-sound-soc-sunxi
+ SUPPORTED_DEVICES += marsboard,a10-marsboard
+ SOC := sun4i
+endef
+TARGET_DEVICES += haoyu_a10-marsboard
+
define Device/linksprite_a10-pcduino
DEVICE_VENDOR := LinkSprite
DEVICE_MODEL := pcDuino
@@ -19,15 +29,6 @@ define Device/linksprite_a10-pcduino
endef
TARGET_DEVICES += linksprite_a10-pcduino
-define Device/marsboard_a10-marsboard
- DEVICE_VENDOR := HAOYU Electronics
- DEVICE_MODEL := MarsBoard A10
- DEVICE_PACKAGES:=kmod-ata-core kmod-ata-sunxi kmod-sun4i-emac \
- kmod-rtc-sunxi kmod-sound-core kmod-sound-soc-sunxi
- SOC := sun4i
-endef
-TARGET_DEVICES += marsboard_a10-marsboard
-
define Device/olimex_a10-olinuxino-lime
DEVICE_VENDOR := Olimex
DEVICE_MODEL := A10-OLinuXino-LIME