summaryrefslogtreecommitdiffstats
path: root/target/linux/x86/modules.mk
diff options
context:
space:
mode:
authorAlberto Bursi <bobafetthotmail@gmail.com>2021-02-06 20:25:32 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2021-03-01 00:34:23 +0100
commit788ec9a7cfc843c8e46451331521cdc7d81866bd (patch)
tree9de7edb098e4da10478b617edbfd5c66b3205f44 /target/linux/x86/modules.mk
parent0c0c9c734d216b69f404a80eab4f9989a4fc9d42 (diff)
downloadopenwrt-788ec9a7cfc843c8e46451331521cdc7d81866bd.tar.gz
openwrt-788ec9a7cfc843c8e46451331521cdc7d81866bd.tar.bz2
openwrt-788ec9a7cfc843c8e46451331521cdc7d81866bd.zip
x86: add support for AWS T3 instances
Amazon AWS T3 cloud instances require kernel support for the Elastic Fabric Adapter to access storage and for Elastic Network Adapter to use network interfaces. Since the Fabric Adapter is needed to access root filesystem, enable in x86_64 kernel. Elastic Network Adapter goes in a module, and add this module to default list in x86_64. The module is set to AutoLoad because AutoProbe does not seem to load it. Signed-off-by: Alberto Bursi <bobafetthotmail@gmail.com>
Diffstat (limited to 'target/linux/x86/modules.mk')
-rw-r--r--target/linux/x86/modules.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/x86/modules.mk b/target/linux/x86/modules.mk
index 24a4384577..6ab80d03d9 100644
--- a/target/linux/x86/modules.mk
+++ b/target/linux/x86/modules.mk
@@ -2,6 +2,23 @@
#
# Copyright (C) 2017 Cezary Jackiewicz <cezary@eko.one.pll>
+define KernelPackage/amazon-ena
+ SUBMENU:=$(NETWORK_DEVICES_MENU)
+ TITLE:=Elastic Network Adapter (for Amazon AWS T3)
+ DEPENDS:=@TARGET_x86_64
+ KCONFIG:=CONFIG_ENA_ETHERNET
+ FILES:=$(LINUX_DIR)/drivers/net/ethernet/amazon/ena/ena.ko
+ AUTOLOAD:=$(call AutoLoad,12,ena)
+endef
+
+define KernelPackage/amazon-ena/description
+ This driver supports Elastic Network Adapter (ENA)
+ used by Amazon AWS T3 instances.
+endef
+
+$(eval $(call KernelPackage,amazon-ena))
+
+
define KernelPackage/sound-cs5535audio
TITLE:=CS5535/CS5536 Audio Controller
DEPENDS:=@TARGET_x86_geode +kmod-ac97