summaryrefslogtreecommitdiffstats
path: root/target/linux/x86
diff options
context:
space:
mode:
authorTil Kaiser <til.kaiser@gmx.de>2023-11-09 14:28:45 +0100
committerPetr Štetiar <ynezz@true.cz>2023-12-23 07:52:05 +0000
commit713dc12960dd6146706a364905904b58d4d586d4 (patch)
tree3661cff5c866866cd56df0823f4c54a0c607d429 /target/linux/x86
parent4a2ff73177992abcb30f164358b3692ac9fbdc52 (diff)
downloadopenwrt-713dc12960dd6146706a364905904b58d4d586d4.tar.gz
openwrt-713dc12960dd6146706a364905904b58d4d586d4.tar.bz2
openwrt-713dc12960dd6146706a364905904b58d4d586d4.zip
Revert "x86: add support for Mellanox Spectrum SN2000 Switches"
This reverts commit 3004c20614fdb29732f750417a578274a8ed988e. The commit added the needed packages for the new target to the generic x86_64 image. This results into unwanted modules and firmware files for other x86 devices. Additionally, there is the following error message while booting the image on other x86 devices: [ 8.531720] kmodloader: 1 module could not be probed [ 8.532613] kmodloader: - leds-mlxcpld - 0 For now, the needed packages will have to be selected manually while configuring the image. Signed-off-by: Til Kaiser <til.kaiser@gmx.de>
Diffstat (limited to 'target/linux/x86')
-rw-r--r--target/linux/x86/base-files/etc/board.d/02_network3
-rw-r--r--target/linux/x86/image/64.mk6
2 files changed, 1 insertions, 8 deletions
diff --git a/target/linux/x86/base-files/etc/board.d/02_network b/target/linux/x86/base-files/etc/board.d/02_network
index b18ab60120..5174906264 100644
--- a/target/linux/x86/base-files/etc/board.d/02_network
+++ b/target/linux/x86/base-files/etc/board.d/02_network
@@ -31,9 +31,6 @@ cisco-mx100-hw)
ucidef_set_network_device_path "eth11" "pci0000:00/0000:00:01.1/0000:02:00.2"
ucidef_set_interfaces_lan_wan "mgmt eth2 eth3 eth4 eth5 eth6 eth7 eth8 eth9 eth10 eth11" "wan"
;;
-mellanox-technologies-ltd-msn2100)
- ucidef_set_interface_lan "eth1 eth2 eth3 eth4 eth5 eth6 eth7 eth8 eth9 eth10 eth11 eth12 eth13 eth14 eth15 eth16"
- ;;
pc-engines-apu1|pc-engines-apu2|pc-engines-apu3)
ucidef_set_interfaces_lan_wan "eth1 eth2" "eth0"
;;
diff --git a/target/linux/x86/image/64.mk b/target/linux/x86/image/64.mk
index f3d795ea22..7bc79006d3 100644
--- a/target/linux/x86/image/64.mk
+++ b/target/linux/x86/image/64.mk
@@ -4,11 +4,7 @@ define Device/generic
DEVICE_PACKAGES += \
kmod-amazon-ena kmod-amd-xgbe kmod-bnx2 kmod-dwmac-intel kmod-e1000e kmod-e1000 \
kmod-forcedeth kmod-fs-vfat kmod-igb kmod-igc kmod-ixgbe kmod-r8169 \
- kmod-tg3 kmod-mlxsw-core kmod-mlxsw-pci kmod-mlxsw-i2c \
- kmod-mlxsw-spectrum kmod-mlxsw-minimal kmod-mlxfw \
- kmod-leds-mlxcpld kmod-lib-objagg kmod-lib-parman \
- kmod-hwmon-coretemp kmod-hwmon-drivetemp kmod-hwmon-jc42 \
- kmod-i2c-i801 mlxsw_spectrum-firmware
+ kmod-tg3
GRUB2_VARIANT := generic
endef
TARGET_DEVICES += generic