summaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorJayantajit Gogoi <jayanta.gogoi525@gmail.com>2023-08-29 18:23:30 +0000
committerJayantajit Gogoi <30702133+jayanta525@users.noreply.github.com>2023-09-05 00:20:51 +0530
commit1b15cb21db6dafed9a43bb3258e6fa3481080192 (patch)
tree88eefb5807966a9feacbf8d0468e14c3d861843e /target/linux
parent18b6bae851742605a9b213debec1b360e00cc9bd (diff)
downloadopenwrt-1b15cb21db6dafed9a43bb3258e6fa3481080192.tar.gz
openwrt-1b15cb21db6dafed9a43bb3258e6fa3481080192.tar.bz2
openwrt-1b15cb21db6dafed9a43bb3258e6fa3481080192.zip
rockchip: add support for Radxa ROCK Pi E
This adds support for Radxa ROCK Pi E, rockchip rk3328 board. Specification: - CPU: Rockchip RK3328 64-bit Quad-core - RAM: DDR3 256MB ~ 2GB - Network: 1 x 10/100/1000M Ethernet 1 x 10/100M Ethernet - Storage: 1 x MicroSD Slot 1 x eMMC Module Slot - USB Host/OTG: 1 x USB3.0 Type A HOST 1 x USB2.0 HOST (40-pin pin-header) - Wireless RTL8723DU/RTL8821CU - Debug Serial: 1500000 baud at UART2 ( 40-pin pin-header) - Power Supply: Type-C 5V Optionally PoE Installation: - Write image to SD Card or EMMC with dd - Boot ROCK Pi E from the SD Card Signed-off-by: Jayantajit Gogoi <jayanta.gogoi525@gmail.com>
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/rockchip/image/armv8.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/rockchip/image/armv8.mk b/target/linux/rockchip/image/armv8.mk
index df16505d29..dd6a2d5bfe 100644
--- a/target/linux/rockchip/image/armv8.mk
+++ b/target/linux/rockchip/image/armv8.mk
@@ -79,6 +79,15 @@ define Device/radxa_rock-pi-4a
endef
TARGET_DEVICES += radxa_rock-pi-4a
+define Device/radxa_rock-pi-e
+ DEVICE_VENDOR := Radxa
+ DEVICE_MODEL := ROCK Pi E
+ SOC := rk3328
+ UBOOT_DEVICE_NAME := rock-pi-e-rk3328
+ IMAGE/sysupgrade.img.gz := boot-common | boot-script | pine64-img | gzip | append-metadata
+endef
+TARGET_DEVICES += radxa_rock-pi-e
+
define Device/xunlong_orangepi-r1-plus
DEVICE_VENDOR := Xunlong
DEVICE_MODEL := Orange Pi R1 Plus