summaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorZoltan HERPAI <wigyori@uid0.hu>2023-10-27 18:23:57 +0200
committerZoltan HERPAI <wigyori@uid0.hu>2024-05-04 00:41:02 +0200
commit3f7d8e20cd1b56bf6c8e20cb984724ae1fa7525c (patch)
treeb9a94a648b543a59d4c0bee39e7a3afe910e67b9 /target/linux
parent263fde5ab87bc3f299e4bd2d33a22e0fe55f9545 (diff)
downloadopenwrt-3f7d8e20cd1b56bf6c8e20cb984724ae1fa7525c.tar.gz
openwrt-3f7d8e20cd1b56bf6c8e20cb984724ae1fa7525c.tar.bz2
openwrt-3f7d8e20cd1b56bf6c8e20cb984724ae1fa7525c.zip
sunxi: add support for Lichee Pi Zero Dock (V3s) board
CPU: Allwinner V3s single-core Cortex-A7 @ 1.2GHz Memory: 64Mb DDR2 integrated into SoC package Storage: 1x SDcard on board, 1x SDcard on dock Network: 10/100M ethernet Other: 4x buttons via LRADC, CSI Flashing instructions: Standard sunxi SD card installation procedure - copy image to SD card, insert into SD card slot on the device and boot. Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/sunxi/image/cortexa7.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/sunxi/image/cortexa7.mk b/target/linux/sunxi/image/cortexa7.mk
index a85b20531d..e2d83fa94f 100644
--- a/target/linux/sunxi/image/cortexa7.mk
+++ b/target/linux/sunxi/image/cortexa7.mk
@@ -112,6 +112,14 @@ define Device/lemaker_bananapro
endef
TARGET_DEVICES += lemaker_bananapro
+define Device/licheepi_licheepi-zero-dock
+ DEVICE_VENDOR := LicheePi
+ DEVICE_MODEL := Zero with Dock (V3s)
+ DEVICE_PACKAGES:=kmod-rtc-sunxi
+ SOC := sun8i-v3s
+endef
+TARGET_DEVICES += licheepi_licheepi-zero-dock
+
define Device/linksprite_pcduino3
DEVICE_VENDOR := LinkSprite
DEVICE_MODEL := pcDuino3