summaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorMathew McBride <matt@traverse.com.au>2023-02-11 03:58:09 +0000
committerPetr Štetiar <ynezz@true.cz>2023-06-02 11:36:29 +0200
commit5d2a5f739840caa6e72b5c907d355f6aaca227d4 (patch)
tree907371df08dcba410d7f851c2244c416269c3ab8 /target/linux
parent26905c96124af10a795167509116252e9357baea (diff)
downloadopenwrt-5d2a5f739840caa6e72b5c907d355f6aaca227d4.tar.gz
openwrt-5d2a5f739840caa6e72b5c907d355f6aaca227d4.tar.bz2
openwrt-5d2a5f739840caa6e72b5c907d355f6aaca227d4.zip
armvirt: 64: add Marvell (formerly Cavium) ThunderX series network driver
Based on working configuration supplied by Anton Antonov. Signed-off-by: Mathew McBride <matt@traverse.com.au>
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/armvirt/image/Makefile4
-rw-r--r--target/linux/armvirt/modules.mk18
2 files changed, 20 insertions, 2 deletions
diff --git a/target/linux/armvirt/image/Makefile b/target/linux/armvirt/image/Makefile
index 7c4ba60b9b..f1d0acd013 100644
--- a/target/linux/armvirt/image/Makefile
+++ b/target/linux/armvirt/image/Makefile
@@ -108,8 +108,8 @@ define Device/generic
DEVICE_PACKAGES += kmod-amazon-ena kmod-e1000e kmod-vmxnet3 kmod-rtc-rx8025 \
kmod-i2c-mux-pca954x kmod-gpio-pca953x partx-utils kmod-wdt-sp805 \
kmod-mvneta kmod-mvpp2 kmod-fsl-dpaa1-net kmod-fsl-dpaa2-net \
- kmod-fsl-enetc-net kmod-dwmac-imx kmod-fsl-fec kmod-sfp \
- kmod-phy-aquantia kmod-phy-broadcom kmod-phy-marvell \
+ kmod-fsl-enetc-net kmod-dwmac-imx kmod-fsl-fec kmod-thunderx-net \
+ kmod-phy-aquantia kmod-phy-broadcom kmod-phy-marvell kmod-sfp \
kmod-phy-marvell-10g kmod-atlantic
endef
TARGET_DEVICES += generic
diff --git a/target/linux/armvirt/modules.mk b/target/linux/armvirt/modules.mk
index 1ff523c7bd..1531e91bde 100644
--- a/target/linux/armvirt/modules.mk
+++ b/target/linux/armvirt/modules.mk
@@ -234,6 +234,24 @@ endef
$(eval $(call KernelPackage,dwmac-imx))
+define KernelPackage/thunderx-net
+ SUBMENU:=$(NETWORK_DEVICES_MENU)
+ TITLE:=Marvell (Cavium) ThunderX/2 network drivers
+ DEPENDS:=@(TARGET_armvirt_64) +kmod-phylink +kmod-of-mdio
+ KCONFIG:=CONFIG_NET_VENDOR_CAVIUM \
+ CONFIG_THUNDER_NIC_PF \
+ CONFIG_THUNDER_NIC_VF \
+ CONFIG_THUNDER_NIC_BGX \
+ CONFIG_THUNDER_NIC_RGX
+ FILES=$(LINUX_DIR)/drivers/net/ethernet/cavium/thunder/nicvf.ko \
+ $(LINUX_DIR)/drivers/net/ethernet/cavium/thunder/nicpf.ko \
+ $(LINUX_DIR)/drivers/net/ethernet/cavium/thunder/thunder_xcv.ko \
+ $(LINUX_DIR)/drivers/net/ethernet/cavium/thunder/thunder_bgx.ko
+ AUTOLOAD=$(call AutoLoad,40,nicpf nicvf thunder_xcv thunder_bgx)
+endef
+
+$(eval $(call KernelPackage,thunderx-net))
+
define KernelPackage/wdt-sp805
SUBMENU:=$(OTHER_MENU)
TITLE:=ARM SP805 Watchdog