summaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorMarek BehĂșn <kabel@kernel.org>2024-11-15 10:01:35 +0100
committerRobert Marko <robimarko@gmail.com>2024-11-15 13:01:31 +0100
commit749a43325b98afe4430fa7e2f23ac3ee44791ad6 (patch)
tree728d4f9181aeafd5f7b700e85632b029f4562986 /target/linux
parent8c018dcb5601150f26a01babd297e6b416895eba (diff)
downloadopenwrt-749a43325b98afe4430fa7e2f23ac3ee44791ad6.tar.gz
openwrt-749a43325b98afe4430fa7e2f23ac3ee44791ad6.tar.bz2
openwrt-749a43325b98afe4430fa7e2f23ac3ee44791ad6.zip
utils: Add the omnia-eeprom utility
Add a new utility, `omnia-eeprom`, which can be used to print / set EEPROM fields on Turris Omnia. One example when this utility might be useful is if the board experiences random crashes due to newer versions of the DDR training algorithm in newer U-Boot. The user can change the DDR speed from 1600K to 1333H to solve these issues, with ``` omnia-eeprom set ddr_speed 1333H ``` Signed-off-by: Marek BehĂșn <kabel@kernel.org> Link: https://github.com/openwrt/openwrt/pull/16264 Signed-off-by: Robert Marko <robimarko@gmail.com>
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/mvebu/image/cortexa9.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/mvebu/image/cortexa9.mk b/target/linux/mvebu/image/cortexa9.mk
index 6e49045f68..4a41f2c102 100644
--- a/target/linux/mvebu/image/cortexa9.mk
+++ b/target/linux/mvebu/image/cortexa9.mk
@@ -107,7 +107,8 @@ define Device/cznic_turris-omnia
mkf2fs e2fsprogs kmod-fs-vfat kmod-nls-cp437 kmod-nls-iso8859-1 \
wpad-basic-mbedtls kmod-ath9k kmod-ath10k-ct ath10k-firmware-qca988x-ct \
kmod-mt7915-firmware partx-utils kmod-i2c-mux-pca954x kmod-leds-turris-omnia \
- kmod-turris-omnia-mcu kmod-gpio-button-hotplug omnia-mcu-firmware omnia-mcutool
+ kmod-turris-omnia-mcu kmod-gpio-button-hotplug omnia-eeprom omnia-mcu-firmware \
+ omnia-mcutool
IMAGES := sysupgrade.img.gz
IMAGE/sysupgrade.img.gz := boot-scr | boot-img | sdcard-img | gzip | append-metadata
SUPPORTED_DEVICES += armada-385-turris-omnia