summaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorThomas Bong <thomas.bong@devolo.de>2023-08-31 07:39:24 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2023-09-03 23:11:40 +0200
commit838bb0c03f2c9953fa677779112e6f441fe740b9 (patch)
tree1c8b506b6f1e74fad35053ee90025bdc50795911 /target/linux
parent6267961a4a53da6897d0445fdfa1fa7880aea6a7 (diff)
downloadopenwrt-838bb0c03f2c9953fa677779112e6f441fe740b9.tar.gz
openwrt-838bb0c03f2c9953fa677779112e6f441fe740b9.tar.bz2
openwrt-838bb0c03f2c9953fa677779112e6f441fe740b9.zip
ipq40xx: convert devolo Magic 2 WiFi next to DSA
Renamed the interfaces to match the other devices. Name the interface connected to the builtin G.hn chip 'ghn'. This might toggle at runtime while the G.hn chip is in the bootloader. Reviewed-by: Robert Marko <robimarko@gmail.com> Signed-off-by: Thomas Bong <thomas.bong@devolo.de>
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ipq40xx/base-files/etc/board.d/02_network3
-rw-r--r--target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-magic-2-wifi-next.dts23
-rw-r--r--target/linux/ipq40xx/image/generic.mk2
3 files changed, 27 insertions, 1 deletions
diff --git a/target/linux/ipq40xx/base-files/etc/board.d/02_network b/target/linux/ipq40xx/base-files/etc/board.d/02_network
index 77dc892d07..951e0ad044 100644
--- a/target/linux/ipq40xx/base-files/etc/board.d/02_network
+++ b/target/linux/ipq40xx/base-files/etc/board.d/02_network
@@ -69,6 +69,9 @@ ipq40xx_setup_interfaces()
compex,wpj428)
ucidef_set_interface_lan "lan1 lan2"
;;
+ devolo,magic-2-wifi-next)
+ ucidef_set_interface_lan "lan1 lan2 ghn"
+ ;;
linksys,whw01)
ucidef_set_interface_lan "eth1 eth2"
;;
diff --git a/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-magic-2-wifi-next.dts b/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-magic-2-wifi-next.dts
index 29d51aa9e1..1fbc02d62b 100644
--- a/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-magic-2-wifi-next.dts
+++ b/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-magic-2-wifi-next.dts
@@ -231,3 +231,26 @@
};
};
};
+
+&gmac {
+ status = "okay";
+};
+
+&switch {
+ status = "okay";
+};
+
+&swport5 {
+ status = "okay";
+ label = "lan1";
+};
+
+&swport3 {
+ status = "okay";
+ label = "lan2";
+};
+
+&swport4 {
+ status = "okay";
+ label = "ghn";
+};
diff --git a/target/linux/ipq40xx/image/generic.mk b/target/linux/ipq40xx/image/generic.mk
index 56aad5062e..58836471f0 100644
--- a/target/linux/ipq40xx/image/generic.mk
+++ b/target/linux/ipq40xx/image/generic.mk
@@ -388,7 +388,7 @@ define Device/devolo_magic-2-wifi-next
DEFAULT := n
endef
# Missing DSA Setup
-#TARGET_DEVICES += devolo_magic-2-wifi-next
+TARGET_DEVICES += devolo_magic-2-wifi-next
define Device/dlink_dap-2610
$(call Device/FitImageLzma)