summaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorAndreas Böhler <dev@aboehler.at>2023-09-12 19:57:55 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2023-09-18 11:49:37 +0200
commita9cc3708e0c3c4869711a9ba4b9c1437ed250721 (patch)
tree1c288aef998ed4aded8c8eaab18e91fd4a7bf0cf /target/linux
parent12584395dc5d45333df298554ff73a8b9495e119 (diff)
downloadopenwrt-a9cc3708e0c3c4869711a9ba4b9c1437ed250721.tar.gz
openwrt-a9cc3708e0c3c4869711a9ba4b9c1437ed250721.tar.bz2
openwrt-a9cc3708e0c3c4869711a9ba4b9c1437ed250721.zip
ipq40xx: fix image building for ZTE MF287 series
For the ZTE MF287 series, a special recovery image is built. The Makefile worked fine on snapshot, but created corrupt images on the 23.05 images. By using the appropriate variable, this should be fixed. Signed-off-by: Andreas Böhler <dev@aboehler.at>
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ipq40xx/image/generic.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ipq40xx/image/generic.mk b/target/linux/ipq40xx/image/generic.mk
index 29778156df..8fd7ab2915 100644
--- a/target/linux/ipq40xx/image/generic.mk
+++ b/target/linux/ipq40xx/image/generic.mk
@@ -1162,7 +1162,7 @@ define Device/zte_mf287_common
# exploit for the web interface
IMAGES += factory.bin recovery.bin
IMAGE/factory.bin := append-ubi
- IMAGE/recovery.bin := append-squashfs4-fakeroot | sysupgrade-tar kernel=$$$$(BIN_DIR)/openwrt-$$(BOARD)$$(if $$(SUBTARGET),-$$(SUBTARGET))-$$(DEVICE_NAME)-initramfs-zImage.itb rootfs=$$$$@ | append-metadata
+ IMAGE/recovery.bin := append-squashfs4-fakeroot | sysupgrade-tar kernel=$$$$(BIN_DIR)/$$(KERNEL_INITRAMFS_IMAGE) rootfs=$$$$@ | append-metadata
endef
define Device/zte_mf287plus