summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorRobert Marko <robimarko@gmail.com>2024-11-19 23:38:02 +0100
committerRobert Marko <robimarko@gmail.com>2024-11-20 09:49:21 +0100
commit03eeeffbd62bbba201445e0b79bd3360c896a4c8 (patch)
treefb994e5cbc6aec68d6a2ab9936e2b2b1c0283b68 /target
parent22664498ebdd47aad9b15f62edbcaadd851fd62c (diff)
downloadopenwrt-03eeeffbd62bbba201445e0b79bd3360c896a4c8.tar.gz
openwrt-03eeeffbd62bbba201445e0b79bd3360c896a4c8.tar.bz2
openwrt-03eeeffbd62bbba201445e0b79bd3360c896a4c8.zip
imagebuilder: fix APK package_depends support
Currently trying to use the 'package_depends' feature of ImageBuilder will result in it trying to call OPKG: make package_depends PACKAGE="usbutils" OK: 26 MiB in 142 packages bash: line 1: openwrt-imagebuilder-qualcommax-ipq807x.Linux-x86_64/staging_dir/host/bin/opkg: No such file or directory make: *** [Makefile:363: package_depends] Error 127 It looks like a copy/paste error when APK support was being added, so lets fix it by calling APK and its "info --depends" command. Fixes: #16996 Fixes: d788ab376f85 ("build: add APK package build capabilities") Link: https://github.com/openwrt/openwrt/pull/17022 Signed-off-by: Robert Marko <robimarko@gmail.com>
Diffstat (limited to 'target')
-rw-r--r--target/imagebuilder/files/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/imagebuilder/files/Makefile b/target/imagebuilder/files/Makefile
index 2c6e26e4ee..125cc798fc 100644
--- a/target/imagebuilder/files/Makefile
+++ b/target/imagebuilder/files/Makefile
@@ -363,7 +363,7 @@ endif
ifeq ($(CONFIG_USE_APK),)
@$(OPKG) depends -A $(PACKAGE)
else
- @$(OPKG) whatdepends -A $(PACKAGE)
+ @$(APK) info --depends $(PACKAGE)
endif
.SILENT: help info image manifest package_whatdepends package_depends