summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorIsaac de Wolff <idewolff@gmx.com>2024-12-08 13:52:40 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2024-12-10 21:18:06 +0100
commit0d21cc8a92ea3b2cc94efefd60eae968a4296543 (patch)
tree4565f17140c24290cbc9182ddc959ad240c91d67 /target
parent4234d5ec45b72cb8d53713fab40efc68bedf546e (diff)
downloadopenwrt-0d21cc8a92ea3b2cc94efefd60eae968a4296543.tar.gz
openwrt-0d21cc8a92ea3b2cc94efefd60eae968a4296543.tar.bz2
openwrt-0d21cc8a92ea3b2cc94efefd60eae968a4296543.zip
lantiq: grow kernel partition Zyxel P-2812HNU-F1
Change partition table in dts file. Change DEVICE_COMPAT_VERSION Enable automatic build. To take advantage of the bigger kernel partition, the uboot environment has to be changed: setenv nboot 'nand read 0x81000000 0x60000 0x500000; bootm 0x81000000' setenv bootcmd 'run nboot' saveenv Of course you need a u-boot capable of handling this. The u-boot discussed in this forum thread: https://forum.openwrt.org/t/zyxel-p2812hnu-f1-u-boot/100281 should be able to handle kernels up to an uncompressed size of 16MiB. Signed-off-by: Isaac de Wolff <idewolff@gmx.com> Link: https://github.com/openwrt/openwrt/pull/17209 Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'target')
-rw-r--r--target/linux/lantiq/files/arch/mips/boot/dts/lantiq/vr9_zyxel_p-2812hnu-f1.dts6
-rw-r--r--target/linux/lantiq/image/vr9.mk7
-rw-r--r--target/linux/lantiq/xrx200/base-files/etc/board.d/05_compat-version4
3 files changed, 11 insertions, 6 deletions
diff --git a/target/linux/lantiq/files/arch/mips/boot/dts/lantiq/vr9_zyxel_p-2812hnu-f1.dts b/target/linux/lantiq/files/arch/mips/boot/dts/lantiq/vr9_zyxel_p-2812hnu-f1.dts
index 247b811b4f..58a34d6e27 100644
--- a/target/linux/lantiq/files/arch/mips/boot/dts/lantiq/vr9_zyxel_p-2812hnu-f1.dts
+++ b/target/linux/lantiq/files/arch/mips/boot/dts/lantiq/vr9_zyxel_p-2812hnu-f1.dts
@@ -47,11 +47,11 @@
};
partition@60000 {
label = "kernel";
- reg = <0x60000 0x300000>;
+ reg = <0x60000 0x500000>;
};
- partition@360000 {
+ partition@560000 {
label = "ubi";
- reg = <0x360000 0x7ca0000>;
+ reg = <0x560000 0x7aa0000>;
};
};
};
diff --git a/target/linux/lantiq/image/vr9.mk b/target/linux/lantiq/image/vr9.mk
index d4bded9cae..fe5b5a6bb5 100644
--- a/target/linux/lantiq/image/vr9.mk
+++ b/target/linux/lantiq/image/vr9.mk
@@ -368,16 +368,17 @@ endef
TARGET_DEVICES += netgear_dm200
define Device/zyxel_p-2812hnu-f1
- $(Device/dsa-migration)
$(Device/NAND)
+ DEVICE_COMPAT_VERSION := 2.0
+ DEVICE_COMPAT_MESSAGE := kernel and ubi partitions had to be resized. \
+ Upgrade manually using initramfs, and change u-boot environment to load 5MiB for uImage.
DEVICE_VENDOR := Zyxel
DEVICE_MODEL := P-2812HNU
DEVICE_VARIANT := F1
BOARD_NAME := P2812HNUF1
DEVICE_PACKAGES := kmod-rt2800-pci wpad-basic-mbedtls kmod-usb-dwc2 kmod-usb-ledtrig-usbport
- KERNEL_SIZE := 3072k
+ KERNEL_SIZE := 5120k
SUPPORTED_DEVICES += P2812HNUF1
- DEFAULT := n
endef
TARGET_DEVICES += zyxel_p-2812hnu-f1
diff --git a/target/linux/lantiq/xrx200/base-files/etc/board.d/05_compat-version b/target/linux/lantiq/xrx200/base-files/etc/board.d/05_compat-version
index 45bef9385b..5690d84874 100644
--- a/target/linux/lantiq/xrx200/base-files/etc/board.d/05_compat-version
+++ b/target/linux/lantiq/xrx200/base-files/etc/board.d/05_compat-version
@@ -8,6 +8,10 @@
board_config_update
case "$(board_name)" in
+ zyxel,p-2812hnu-f1)
+ ucidef_set_compat_version "2.0"
+ ;;
+
*)
ucidef_set_compat_version "1.1"
;;