summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2024-02-12 16:59:50 +0100
committerPaul Spooren <mail@aparcar.org>2024-02-12 17:06:41 +0100
commit131e41614dcfae1f995e55330ada6573ca244ba3 (patch)
tree65f2caac878392baa1f903e421258ee34e11a263 /target
parent6497cdba09d6faa04a4f74465ed95ae21e2ff1ff (diff)
downloadopenwrt-131e41614dcfae1f995e55330ada6573ca244ba3.tar.gz
openwrt-131e41614dcfae1f995e55330ada6573ca244ba3.tar.bz2
openwrt-131e41614dcfae1f995e55330ada6573ca244ba3.zip
build: align SOURCE path for build system and SDK
Building a package in the build system or the SDK results in different values for the `SOURCE` property, it's either `packages/<package name>` or `feeds/base/<package name>`. The reason is that the SDK handles `openwrt.git` as an external feed called while the build system contains the *base* packages directly. Since packages created with either method are (ideally) the same (bit for bit), align the content of SOURCE. To do so this commit creates a symlink from `feeds/base` to `$(TOPDIR)/package` and adopts the SOURCE when building from inside the build system. Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'target')
-rw-r--r--target/imagebuilder/files/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/imagebuilder/files/Makefile b/target/imagebuilder/files/Makefile
index 78ec7e2e94..40fba83b5e 100644
--- a/target/imagebuilder/files/Makefile
+++ b/target/imagebuilder/files/Makefile
@@ -106,7 +106,8 @@ PROFILE_LIST = $(foreach p,$(PROFILE_NAMES), \
@$(SCRIPT_DIR)/target-metadata.pl profile_mk $< '$(BOARD)$(if $(SUBTARGET),/$(SUBTARGET))' > $@
staging_dir/host/.prereq-build: include/prereq-build.mk
- mkdir -p tmp
+ mkdir -p tmp feeds
+ ln -sf $(TOPDIR)/package $(TOPDIR)/feeds/base
@$(_SINGLE)$(NO_TRACE_MAKE) -j1 -r -s -f $(TOPDIR)/include/prereq-build.mk prereq IB=1 2>/dev/null || { \
echo "Prerequisite check failed. Use FORCE=1 to override."; \
false; \