summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorRobert Marko <robimarko@gmail.com>2024-12-07 22:08:18 +0100
committerRobert Marko <robimarko@gmail.com>2024-12-08 09:58:38 +0100
commit1b6f7ec6794233fbf7c1cf17dcee34053c08fa9c (patch)
tree5246ee02d7489586e36a0dcaa729f4586009a180 /target
parent9c55866fada91c45679f75d03e6d13e1e0cd4202 (diff)
downloadopenwrt-1b6f7ec6794233fbf7c1cf17dcee34053c08fa9c.tar.gz
openwrt-1b6f7ec6794233fbf7c1cf17dcee34053c08fa9c.tar.bz2
openwrt-1b6f7ec6794233fbf7c1cf17dcee34053c08fa9c.zip
qualcommax: ipq807x: add Netgear DEVICE_VARS
Add NETGEAR_BOARD_ID and NETGEAR_HW_ID to DEVICE_VARS as multiple devices set them in their recipes, so without them being added to DEVICE_VARS then simply the value from last recipe that gets evaluated is used and images are generated with the wrong ID-s. Link: https://github.com/openwrt/openwrt/pull/17203 Signed-off-by: Robert Marko <robimarko@gmail.com>
Diffstat (limited to 'target')
-rw-r--r--target/linux/qualcommax/image/ipq807x.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/qualcommax/image/ipq807x.mk b/target/linux/qualcommax/image/ipq807x.mk
index 34fe92ed54..ff6963405c 100644
--- a/target/linux/qualcommax/image/ipq807x.mk
+++ b/target/linux/qualcommax/image/ipq807x.mk
@@ -1,3 +1,5 @@
+DEVICE_VARS += NETGEAR_BOARD_ID NETGEAR_HW_ID
+
define Build/asus-fake-ramdisk
rm -rf $(KDIR)/tmp/fakerd
dd if=/dev/zero bs=32 count=1 > $(KDIR)/tmp/fakerd