summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2023-12-11 00:24:40 +0000
committerDaniel Golle <daniel@makrotopia.org>2023-12-11 18:01:43 +0000
commit25ddc6e4372ab20c7d2fa45b98b4288bcad932ec (patch)
tree2cc00e8bdfb14f51b37313a687ad0d0909cd05c4 /target
parent4b82a20e770cbff76680f6cf4fa6de42961ada54 (diff)
downloadopenwrt-25ddc6e4372ab20c7d2fa45b98b4288bcad932ec.tar.gz
openwrt-25ddc6e4372ab20c7d2fa45b98b4288bcad932ec.tar.bz2
openwrt-25ddc6e4372ab20c7d2fa45b98b4288bcad932ec.zip
kernel: modules: break-out WM8960 codec module
Package codec module for WM8960 in its own package to be used by more than one target. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ramips/modules.mk11
1 files changed, 5 insertions, 6 deletions
diff --git a/target/linux/ramips/modules.mk b/target/linux/ramips/modules.mk
index 6f199c46a2..1127a8f8ab 100644
--- a/target/linux/ramips/modules.mk
+++ b/target/linux/ramips/modules.mk
@@ -113,18 +113,17 @@ $(eval $(call KernelPackage,hsdma-mtk))
define KernelPackage/sound-mt7620
TITLE:=MT7620 PCM/I2S Alsa Driver
- DEPENDS:=@TARGET_ramips +kmod-sound-soc-core +kmod-regmap-i2c +kmod-dma-ralink @!TARGET_ramips_rt288x
+ DEPENDS:=@TARGET_ramips @!TARGET_ramips_rt288x +kmod-dma-ralink \
+ +kmod-sound-soc-core +kmod-sound-soc-wm8960
KCONFIG:= \
CONFIG_SND_RALINK_SOC_I2S \
CONFIG_SND_SIMPLE_CARD \
- CONFIG_SND_SIMPLE_CARD_UTILS \
- CONFIG_SND_SOC_WM8960
+ CONFIG_SND_SIMPLE_CARD_UTILS
FILES:= \
$(LINUX_DIR)/sound/soc/ralink/snd-soc-ralink-i2s.ko \
$(LINUX_DIR)/sound/soc/generic/snd-soc-simple-card.ko \
- $(LINUX_DIR)/sound/soc/generic/snd-soc-simple-card-utils.ko \
- $(LINUX_DIR)/sound/soc/codecs/snd-soc-wm8960.ko
- AUTOLOAD:=$(call AutoLoad,90,snd-soc-wm8960 snd-soc-ralink-i2s snd-soc-simple-card)
+ $(LINUX_DIR)/sound/soc/generic/snd-soc-simple-card-utils.ko
+ AUTOLOAD:=$(call AutoLoad,90,snd-soc-ralink-i2s snd-soc-simple-card)
$(call AddDepends/sound)
endef