summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorTim Harvey <tharvey@gateworks.com>2023-03-15 12:56:56 -0700
committerRobert Marko <robimarko@gmail.com>2024-02-15 21:21:11 +0100
commit2a21a6918562cb4ced7b282388dc0e9297d3375a (patch)
tree117364cfe0e5dc006c09393637abc064b1c33782 /target
parentb03d3644cfe9eb8db2a3441c55c84b076ba7cd08 (diff)
downloadopenwrt-2a21a6918562cb4ced7b282388dc0e9297d3375a.tar.gz
openwrt-2a21a6918562cb4ced7b282388dc0e9297d3375a.tar.bz2
openwrt-2a21a6918562cb4ced7b282388dc0e9297d3375a.zip
imx: add gpio-button-hotplug to ventana images
Add the gpio-button-hotplug to Gateworks ventana images to support the on-board user pushbutton. Signed-off-by: Tim Harvey <tharvey@gateworks.com>
Diffstat (limited to 'target')
-rw-r--r--target/linux/imx/image/cortexa9.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/imx/image/cortexa9.mk b/target/linux/imx/image/cortexa9.mk
index 2edbbaac47..2321469cc8 100644
--- a/target/linux/imx/image/cortexa9.mk
+++ b/target/linux/imx/image/cortexa9.mk
@@ -120,7 +120,8 @@ define Device/gateworks_ventana
imx6q-gw5913
DEVICE_PACKAGES := kmod-sky2 kmod-sound-core kmod-sound-soc-imx \
kmod-sound-soc-imx-sgtl5000 kmod-can kmod-can-flexcan kmod-can-raw \
- kmod-hwmon-gsc kmod-leds-gpio kmod-pps-gpio kobs-ng
+ kmod-hwmon-gsc kmod-leds-gpio kmod-pps-gpio kobs-ng \
+ kmod-gpio-button-hotplug
KERNEL += | boot-overlay
IMAGES := img.gz nand.ubi bootfs.tar.gz dtb
IMAGE/nand.ubi := append-ubi