summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-11-21 21:25:04 +0000
committerJohn Crispin <john@openwrt.org>2015-11-21 21:25:04 +0000
commit31f9aec7d61f24f50f2ce37a47558afbad410317 (patch)
tree040a9d1fd52fc5e5402707656b8c8610d3029cee /target
parenta429d6998e7352481c6c3ace466be3e35e7fc31a (diff)
downloadopenwrt-31f9aec7d61f24f50f2ce37a47558afbad410317.tar.gz
openwrt-31f9aec7d61f24f50f2ce37a47558afbad410317.tar.bz2
openwrt-31f9aec7d61f24f50f2ce37a47558afbad410317.zip
brcm2708: add support for multi-device images
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> SVN-Revision: 47561
Diffstat (limited to 'target')
-rw-r--r--target/linux/brcm2708/bcm2708/profiles/RaspberryPi.mk34
-rw-r--r--target/linux/brcm2708/image/Makefile24
-rw-r--r--target/linux/brcm2708/image/config.txt2
3 files changed, 16 insertions, 44 deletions
diff --git a/target/linux/brcm2708/bcm2708/profiles/RaspberryPi.mk b/target/linux/brcm2708/bcm2708/profiles/RaspberryPi.mk
index dcf6e0599b..9f698a711d 100644
--- a/target/linux/brcm2708/bcm2708/profiles/RaspberryPi.mk
+++ b/target/linux/brcm2708/bcm2708/profiles/RaspberryPi.mk
@@ -5,34 +5,10 @@
# See /LICENSE for more information.
#
-define Profile/Default
- NAME:=Raspberry Pi
+define Profile/RaspberryPi
+ NAME:=Raspberry Pi Models B/B+/CM
endef
-define Profile/Default/Description
- Raspberry Pi
+define Profile/RaspberryPi/Description
+ Raspberry Pi Models B/B+/CM
endef
-$(eval $(call Profile,Default))
-
-define Profile/RaspberryPi_B
- NAME:=Raspberry Pi Model B
-endef
-define Profile/RaspberryPi_B/Description
- Raspberry Pi Model B
-endef
-$(eval $(call Profile,RaspberryPi_B))
-
-define Profile/RaspberryPi_BPlus
- NAME:=Raspberry Pi Model B+
-endef
-define Profile/RaspberryPi_BPlus/Description
- Raspberry Pi Model B+
-endef
-$(eval $(call Profile,RaspberryPi_BPlus))
-
-define Profile/RaspberryPi_CM
- NAME:=Raspberry Pi Compute Module
-endef
-define Profile/RaspberryPi_CM/Description
- Raspberry Pi Model Compute Module
-endef
-$(eval $(call Profile,RaspberryPi_CM))
+$(eval $(call Profile,RaspberryPi))
diff --git a/target/linux/brcm2708/image/Makefile b/target/linux/brcm2708/image/Makefile
index 22c1218fc7..53e5f54230 100644
--- a/target/linux/brcm2708/image/Makefile
+++ b/target/linux/brcm2708/image/Makefile
@@ -12,9 +12,9 @@ FAT32_BLOCK_SIZE=1024
FAT32_BLOCKS=$(shell echo $$(($(CONFIG_BRCM2708_SD_BOOT_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))
### Image scripts ###
-define Build/gen-cfg
- cat config.txt > $@.config
- echo -e "\ndevice_tree=$(DEVICE_DTS).dtb" >> $@.config
+define Build/kernel-img
+ perl $(LINUX_DIR)/scripts/mkknlimg $@ $@.tmp
+ mv $@.tmp $@
endef
define Build/boot-img
@@ -28,9 +28,9 @@ define Build/boot-img
mcopy -i $@.boot $(KDIR)/fixup.dat ::
mcopy -i $@.boot $(KDIR)/fixup_cd.dat ::
mcopy -i $@.boot cmdline.txt ::
- mcopy -i $@.boot $@.config ::config.txt
+ mcopy -i $@.boot config.txt ::
mcopy -i $@.boot $(word 1,$^) ::kernel.img
- mcopy -i $@.boot $(DTS_DIR)/$(DEVICE_DTS).dtb ::$(DEVICE_DTS).dtb
+ $(foreach dts,$(shell echo $(DEVICE_DTS)),mcopy -i $@.boot $(DTS_DIR)/$(dts).dtb ::)
mmd -i $@.boot ::/overlays
mcopy -i $@.boot $(DTS_DIR)/overlays/*.dtb ::/overlays/
mcopy -i $@.boot $(DTS_DIR)/overlays/README ::/overlays/
@@ -46,9 +46,9 @@ endef
define Device/Default
FILESYSTEMS := ext4
PROFILES = Default $$(DEVICE_PROFILE)
- KERNEL := kernel-bin
+ KERNEL := kernel-bin | kernel-img
IMAGES := sdcard.img
- IMAGE/sdcard.img := gen-cfg | boot-img | sdcard-img
+ IMAGE/sdcard.img := boot-img | sdcard-img
DEVICE_PROFILE :=
DEVICE_DTS :=
endef
@@ -67,18 +67,14 @@ endef
### BCM2708/BCM2835 ###
ifeq ($(SUBTARGET),bcm2708)
- # Raspberry Pi Model B
- $(eval $(call bcm270x,RaspberryPi_B,rpi-b,bcm2708-rpi-b))
- # Raspberry Pi Model B+
- $(eval $(call bcm270x,RaspberryPi_BPlus,rpi-b-plus,bcm2708-rpi-b-plus))
- # Raspberry Pi Compute Module
- $(eval $(call bcm270x,RaspberryPi_CM,rpi-cm,bcm2708-rpi-cm))
+ # Raspberry Pi Models B/B+/CM
+ $(eval $(call bcm270x,RaspberryPi,rpi,bcm2708-rpi-b bcm2708-rpi-b-plus bcm2708-rpi-cm))
endif
### BCM2709/BCM2836 ###
ifeq ($(SUBTARGET),bcm2709)
# Raspberry Pi 2 Model B
- $(eval $(call bcm270x,RaspberryPi_2,rpi-2-b,bcm2709-rpi-2-b))
+ $(eval $(call bcm270x,RaspberryPi_2,rpi-2,bcm2709-rpi-2-b))
endif
$(eval $(call BuildImage))
diff --git a/target/linux/brcm2708/image/config.txt b/target/linux/brcm2708/image/config.txt
index 1fb880f9be..75b1cab7af 100644
--- a/target/linux/brcm2708/image/config.txt
+++ b/target/linux/brcm2708/image/config.txt
@@ -476,7 +476,7 @@
## Stop start.elf from filling in ATAGS (memory from 0x100) before
## launching kernel
##
-disable_commandline_tags=1
+disable_commandline_tags=2
## cmdline (string)
## Command line parameters. Can be used instead of cmdline.txt file