summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorLinus Walleij <linus.walleij@linaro.org>2023-05-31 23:21:07 +0200
committerChristian Lamparter <chunkeey@gmail.com>2023-06-01 23:54:20 +0200
commit33abdc07fbc1e6fb2e0d946187ff88c5270d76a6 (patch)
treee4cfd61c32efe83d80b79a01b6ff63567dd0c87c /target
parent9c1b3966150f9340b169f5adc1bf80dc1cfa54e0 (diff)
downloadopenwrt-33abdc07fbc1e6fb2e0d946187ff88c5270d76a6.tar.gz
openwrt-33abdc07fbc1e6fb2e0d946187ff88c5270d76a6.tar.bz2
openwrt-33abdc07fbc1e6fb2e0d946187ff88c5270d76a6.zip
kernel: Package the new FOTG210 module properly
When using the Gemini, we apply patches that create a single module that support both host and device mode these days. Signed-off-by: Linus Walleij <linus.walleij@linaro.org> (move module to gemini target, keep both 6.1+2-ish + 5.15 module CONFIG and files around until 5.15 is dropped) Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target')
-rw-r--r--target/linux/gemini/modules.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/gemini/modules.mk b/target/linux/gemini/modules.mk
new file mode 100644
index 0000000000..104ad90279
--- /dev/null
+++ b/target/linux/gemini/modules.mk
@@ -0,0 +1,14 @@
+define KernelPackage/usb-fotg210
+ TITLE:=Support for FOTG210 USB host and device controllers
+ DEPENDS:=@USB_SUPPORT @TARGET_gemini
+ KCONFIG:=CONFIG_USB_FOTG210 \
+ CONFIG_USB_FOTG210_HCD
+ FILES:=$(if $(CONFIG_USB_FOTG210_HCD),$(LINUX_DIR)/drivers/usb/host/fotg210-hcd.ko@lt6.1) \
+ $(if $(CONFIG_USB_FOTG210),$(LINUX_DIR)/drivers/usb/fotg210/fotg210.ko@ge6.1)
+ AUTOLOAD:=$(call AutoLoad,50, \
+ $(if $(CONFIG_USB_FOTG210_HCD),fotg210-hcd@lt6.1) \
+ $(if $(CONFIG_USB_FOTG210),fotg210@ge6.1),1)
+ $(call AddDepends/usb)
+endef
+
+$(eval $(call KernelPackage,usb-fotg210))