summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2023-11-26 23:04:04 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2023-11-29 23:43:01 +0100
commit4211eab085ba38be024dc27731ee8135a671a8e8 (patch)
tree9b8ec4da635135663cb7dc990bde0dad120af28f /target
parent6c118efc01a65c064934ec41b8108cb45e00c128 (diff)
downloadopenwrt-4211eab085ba38be024dc27731ee8135a671a8e8.tar.gz
openwrt-4211eab085ba38be024dc27731ee8135a671a8e8.tar.bz2
openwrt-4211eab085ba38be024dc27731ee8135a671a8e8.zip
target: Make TARGET_SERIAL independent of GRUB configuration
GRUB_SERIAL is also used for the default serial on the target and not only in grub. When no grub was build it was not available and the build fails. Rename GRUB_SERIAL to TARGET_SERIAL and make it always available on x86 and armsr targets. Fixes: #14063 Fixes: b10768476f9d ("x86,armsr: interpolate GRUB_SERIAL into /etc/inittab") Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'target')
-rw-r--r--target/linux/armsr/base-files.mk4
-rw-r--r--target/linux/armsr/image/Makefile2
-rw-r--r--target/linux/x86/base-files.mk4
-rw-r--r--target/linux/x86/image/Makefile2
4 files changed, 6 insertions, 6 deletions
diff --git a/target/linux/armsr/base-files.mk b/target/linux/armsr/base-files.mk
index 88ba97d38a..e2b7d05f57 100644
--- a/target/linux/armsr/base-files.mk
+++ b/target/linux/armsr/base-files.mk
@@ -1,6 +1,6 @@
-GRUB_SERIAL:=$(call qstrip,$(CONFIG_GRUB_SERIAL))
+GRUB_SERIAL:=$(call qstrip,$(CONFIG_TARGET_SERIAL))
ifeq ($(GRUB_SERIAL),)
-$(error This platform requires CONFIG_GRUB_SERIAL be set!)
+$(error This platform requires CONFIG_TARGET_SERIAL be set!)
endif
define Package/base-files/install-target
diff --git a/target/linux/armsr/image/Makefile b/target/linux/armsr/image/Makefile
index e5be3fbe38..ec566c5818 100644
--- a/target/linux/armsr/image/Makefile
+++ b/target/linux/armsr/image/Makefile
@@ -15,7 +15,7 @@ ifneq ($(CONFIG_GRUB_CONSOLE),)
GRUB_TERMINALS += console
endif
-GRUB_SERIAL:=$(call qstrip,$(CONFIG_GRUB_SERIAL))
+GRUB_SERIAL:=$(call qstrip,$(CONFIG_TARGET_SERIAL))
GRUB_SERIAL_CONFIG := serial --unit=0 --speed=$(CONFIG_GRUB_BAUDRATE) --word=8 --parity=no --stop=1 --rtscts=$(if $(CONFIG_GRUB_FLOWCONTROL),on,off)
GRUB_TERMINALS += serial
diff --git a/target/linux/x86/base-files.mk b/target/linux/x86/base-files.mk
index 88ba97d38a..e2b7d05f57 100644
--- a/target/linux/x86/base-files.mk
+++ b/target/linux/x86/base-files.mk
@@ -1,6 +1,6 @@
-GRUB_SERIAL:=$(call qstrip,$(CONFIG_GRUB_SERIAL))
+GRUB_SERIAL:=$(call qstrip,$(CONFIG_TARGET_SERIAL))
ifeq ($(GRUB_SERIAL),)
-$(error This platform requires CONFIG_GRUB_SERIAL be set!)
+$(error This platform requires CONFIG_TARGET_SERIAL be set!)
endif
define Package/base-files/install-target
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index d95fd15f00..6e59f2e465 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -16,7 +16,7 @@ ifneq ($(CONFIG_GRUB_CONSOLE),)
GRUB_TERMINALS += console
endif
-GRUB_SERIAL:=$(call qstrip,$(CONFIG_GRUB_SERIAL))
+GRUB_SERIAL:=$(call qstrip,$(CONFIG_TARGET_SERIAL))
GRUB_CONSOLE_CMDLINE += console=$(GRUB_SERIAL),$(CONFIG_GRUB_BAUDRATE)n8$(if $(CONFIG_GRUB_FLOWCONTROL),r,)
GRUB_SERIAL_CONFIG := serial --unit=0 --speed=$(CONFIG_GRUB_BAUDRATE) --word=8 --parity=no --stop=1 --rtscts=$(if $(CONFIG_GRUB_FLOWCONTROL),on,off)