summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorRussell Senior <russell@personaltelco.net>2023-12-01 13:48:56 -0800
committerStijn Tintel <stijn@linux-ipv6.be>2023-12-02 14:06:56 +0200
commit643a4adf9a468f9e3c52efd7de257d50e612a761 (patch)
treeb8016065ac48cc009edf466cb0c1d988fac7cfb9 /target
parentc342bdca878837ba02ed09eba7fbe3175e3a3b87 (diff)
downloadopenwrt-643a4adf9a468f9e3c52efd7de257d50e612a761.tar.gz
openwrt-643a4adf9a468f9e3c52efd7de257d50e612a761.tar.bz2
openwrt-643a4adf9a468f9e3c52efd7de257d50e612a761.zip
qoriq: pad rootfs with zeros
Presently, sysupgrade -n does *not* reset the overlayfs, retaining unwanted filesystem contents. Adding PADDING=1 in front of gen_image_generic.sh in image/Makefile ensures that the overlayfs is recreated on firstboot. Fixes: 080a769b4da8 ("qoriq: new target") Signed-off-by: Russell Senior <russell@personaltelco.net> [add Fixes tag, rewrite commit subject and message to respect line length] Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Diffstat (limited to 'target')
-rw-r--r--target/linux/qoriq/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/qoriq/image/Makefile b/target/linux/qoriq/image/Makefile
index ec46e4d543..69fea238b5 100644
--- a/target/linux/qoriq/image/Makefile
+++ b/target/linux/qoriq/image/Makefile
@@ -13,7 +13,7 @@ define Build/sdcard-img
$(foreach dtb,$(DEVICE_DTS),$(CP) $(KDIR)/image-$(dtb).dtb $@.boot), \
$(CP) $(KDIR)/image-/*.dtb $@.boot)
- $(SCRIPT_DIR)/gen_image_generic.sh \
+ PADDING=1 $(SCRIPT_DIR)/gen_image_generic.sh \
$@ \
$(CONFIG_TARGET_KERNEL_PARTSIZE) $@.boot \
$(CONFIG_TARGET_ROOTFS_PARTSIZE) $(IMAGE_ROOTFS) \