summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorMichael Pratt <mcpratt@pm.me>2023-05-07 19:33:40 -0400
committerChristian Marangi <ansuelsmth@gmail.com>2023-05-09 00:52:31 +0200
commit7bfe7e06767767914f42785d12d2fceca189854e (patch)
tree56b0cc1443fcaff08353c4b6fa0726a281574060 /target
parent91e3419a33f3f0baa2fb25680f5c9a7b2240102b (diff)
downloadopenwrt-7bfe7e06767767914f42785d12d2fceca189854e.tar.gz
openwrt-7bfe7e06767767914f42785d12d2fceca189854e.tar.bz2
openwrt-7bfe7e06767767914f42785d12d2fceca189854e.zip
sdk: do not exclude all doc directories
Some packages which are using local gnulib source are expecting files to exist in the directory: staging_dir/host/share/gnulib/doc so delete the other doc directories directly instead of excluding all of them. Fixes: d167adbc4 ("gettext-full: bootstrap to local gnulib source") Signed-off-by: Michael Pratt <mcpratt@pm.me>
Diffstat (limited to 'target')
-rw-r--r--target/sdk/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/sdk/Makefile b/target/sdk/Makefile
index d9f67dae9e..b688eb4cba 100644
--- a/target/sdk/Makefile
+++ b/target/sdk/Makefile
@@ -32,7 +32,6 @@ EXCLUDE_DIRS:= \
*.install.clean \
*.install.flags \
*.install \
- */doc \
*/share/locale
SDK_DIRS = \
@@ -158,6 +157,8 @@ $(BIN_DIR)/$(SDK_NAME).tar.xz: clean
$(SDK_BUILD_DIR)/package/kernel/
-rm -rf $(SDK_BUILD_DIR)/$(STAGING_SUBDIR_HOST)/.prereq-build
+ -rm -rf $(SDK_BUILD_DIR)/$(STAGING_SUBDIR_HOST)/doc
+ -rm -rf $(SDK_BUILD_DIR)/$(STAGING_SUBDIR_HOST)/share/doc
-rm -f $(SDK_BUILD_DIR)/feeds.conf.default
$(if $(BASE_FEED),echo "$(BASE_FEED)" > $(SDK_BUILD_DIR)/feeds.conf.default)