summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorMathew McBride <matt@traverse.com.au>2023-04-20 06:38:22 +0000
committerPetr Štetiar <ynezz@true.cz>2023-06-02 11:36:15 +0200
commit9a76b99c1bd781248c18d69abe570f35932db8a3 (patch)
tree021095d22f94346f349b0a79e4acdc17cd847168 /target
parent701d774f54aef2f9fe3c584700773dcb260dd03c (diff)
downloadopenwrt-9a76b99c1bd781248c18d69abe570f35932db8a3.tar.gz
openwrt-9a76b99c1bd781248c18d69abe570f35932db8a3.tar.bz2
openwrt-9a76b99c1bd781248c18d69abe570f35932db8a3.zip
armvirt: set kernel partition as the EFI system partition
U-Boot with EFI boot manager functionality will store EFI boot order data on the ESP in the ubootefi.var file. Signed-off-by: Mathew McBride <matt@traverse.com.au>
Diffstat (limited to 'target')
-rw-r--r--target/linux/armvirt/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/armvirt/image/Makefile b/target/linux/armvirt/image/Makefile
index bd75f85996..50c993b522 100644
--- a/target/linux/armvirt/image/Makefile
+++ b/target/linux/armvirt/image/Makefile
@@ -45,7 +45,7 @@ define Build/combined
$(CP) $(STAGING_DIR_IMAGE)/grub2/boot$(if $(CONFIG_aarch64),aa64,arm).efi $@.boot/efi/openwrt/
$(CP) $(STAGING_DIR_IMAGE)/grub2/boot$(if $(CONFIG_aarch64),aa64,arm).efi $@.boot/efi/boot/
)
- FAT_TYPE="32" PADDING="1" SIGNATURE="$(IMG_PART_SIGNATURE)" \
+ KERNELPARTTYPE=ef FAT_TYPE="32" PADDING="1" SIGNATURE="$(IMG_PART_SIGNATURE)" \
$(if $(filter $(1),efi),GUID="$(IMG_PART_DISKGUID)") $(SCRIPT_DIR)/gen_image_generic.sh \
$@ \
$(CONFIG_TARGET_KERNEL_PARTSIZE) $@.boot \