summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorRussell Senior <russell@personaltelco.net>2019-09-21 01:58:07 -0700
committerChristian Lamparter <chunkeey@gmail.com>2019-09-21 23:41:31 +0200
commita03219ba09a55ad49926e5c2d60ddff095fe5096 (patch)
tree89a48c56ea957950ddd460d81ddba01be1c2be4e /target
parent00ed75f47f4726dff17c6d63d6847bc4f7a74970 (diff)
downloadopenwrt-a03219ba09a55ad49926e5c2d60ddff095fe5096.tar.gz
openwrt-a03219ba09a55ad49926e5c2d60ddff095fe5096.tar.bz2
openwrt-a03219ba09a55ad49926e5c2d60ddff095fe5096.zip
apm821xx: remove unnecessary kernel padding
The allocation of LEBs to ubi volumes is handled by the sysupgrade script: package/base-files/files/lib/upgrade/nand.sh and the ubimkvol and or ubirsvol command. Therefore, padding of the kernel blob is not needed at all, so use cat instead of dd. The BLOCKSIZE variable was only used in the dd command. In any case, 63k made no sense for the way BLOCKSIZE was being used. 63k (64512) does make sense for DTB_SIZE because of the offsets expected by u-boot given extant u-boot-env variables. Tested on Meraki MR24. Signed-off-by: Russell Senior <russell@personaltelco.net>
Diffstat (limited to 'target')
-rw-r--r--target/linux/apm821xx/image/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/target/linux/apm821xx/image/Makefile b/target/linux/apm821xx/image/Makefile
index 8203de39c5..108f63cb7a 100644
--- a/target/linux/apm821xx/image/Makefile
+++ b/target/linux/apm821xx/image/Makefile
@@ -58,7 +58,7 @@ define Build/MerakiAdd-dtb
$(call Image/BuildDTB,../dts/$(DEVICE_DTS).dts,$@.dtb)
( \
dd if=$@.dtb bs=$(DTB_SIZE) conv=sync; \
- dd if=$@ bs=$(BLOCKSIZE) conv=sync; \
+ cat $@ ; \
) > $@.new
@mv $@.new $@
endef
@@ -127,7 +127,6 @@ define Device/meraki_mr24
DEVICE_PACKAGES := kmod-spi-gpio -swconfig
BOARD_NAME := mr24
DEVICE_DTS := meraki-mr24
- BLOCKSIZE := 63k
IMAGES := sysupgrade.bin
DTB_SIZE := 64512
IMAGE_SIZE := 8191k