summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorTee Hao Wei <angelsl@in04.sg>2021-05-18 03:46:36 +0800
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-06-05 23:39:14 +0200
commitb232680f847f4ea8d058849a51dedebb8e398a01 (patch)
tree38a72cc900d164067232717d05cc9fc79bdbfa9e /target
parent6d23e474ad9d0eba935696c66db4fb6e2037bb72 (diff)
downloadopenwrt-b232680f847f4ea8d058849a51dedebb8e398a01.tar.gz
openwrt-b232680f847f4ea8d058849a51dedebb8e398a01.tar.bz2
openwrt-b232680f847f4ea8d058849a51dedebb8e398a01.zip
ramips: add support for Linksys EA8100 v1
Specifications: - SoC: MT7621AT - RAM: 256MB - Flash: 128MB NAND - Ethernet: 5 Gigabit ports - WiFi: 2.4G/5G MT7615N - USB: 1 USB 3.0, 1 USB 2.0 This device is very similar to the EA7300 v1/v2 and EA7500 v2. Installation: Upload the generated factory image through the factory web interface. (following part taken from EA7300 v2 commit message:) This might fail due to the A/B nature of this device. When flashing, OEM firmware writes over the non-booted partition. If booted from 'A', flashing over 'B' won't work. To get around this, you should flash the OEM image over itself. This will then boot the router from 'B' and allow you to flash OpenWRT without problems. Reverting to factory firmware: Hard-reset the router three times to force it to boot from 'B.' This is where the stock firmware resides. To remove any traces of OpenWRT from your router simply flash the OEM image at this point. With thanks to Leon Poon (@LeonPoon) for the initial bringup. Signed-off-by: Tee Hao Wei <angelsl@in04.sg> [add missing entry in 10_fix_wifi_mac] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ramips/dts/mt7621_linksys_ea8100-v1.dts8
-rw-r--r--target/linux/ramips/image/mt7621.mk8
-rw-r--r--target/linux/ramips/mt7621/base-files/etc/board.d/01_leds3
-rw-r--r--target/linux/ramips/mt7621/base-files/etc/board.d/02_network3
-rw-r--r--target/linux/ramips/mt7621/base-files/etc/hotplug.d/ieee80211/10_fix_wifi_mac3
-rwxr-xr-xtarget/linux/ramips/mt7621/base-files/etc/init.d/bootcount3
-rwxr-xr-xtarget/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh1
7 files changed, 25 insertions, 4 deletions
diff --git a/target/linux/ramips/dts/mt7621_linksys_ea8100-v1.dts b/target/linux/ramips/dts/mt7621_linksys_ea8100-v1.dts
new file mode 100644
index 0000000000..6cc2219aec
--- /dev/null
+++ b/target/linux/ramips/dts/mt7621_linksys_ea8100-v1.dts
@@ -0,0 +1,8 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7621_linksys_ea7xxx.dtsi"
+
+/ {
+ compatible = "linksys,ea8100-v1", "mediatek,mt7621-soc";
+ model = "Linksys EA8100";
+};
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 4b8ec4ceb1..96a66b2398 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -854,6 +854,14 @@ define Device/linksys_ea7500-v2
endef
TARGET_DEVICES += linksys_ea7500-v2
+define Device/linksys_ea8100-v1
+ $(Device/linksys_ea7xxx)
+ DEVICE_MODEL := EA8100
+ DEVICE_VARIANT := v1
+ LINKSYS_HWNAME := EA8100
+endef
+TARGET_DEVICES += linksys_ea8100-v1
+
define Device/linksys_re6500
$(Device/dsa-migration)
IMAGE_SIZE := 7872k
diff --git a/target/linux/ramips/mt7621/base-files/etc/board.d/01_leds b/target/linux/ramips/mt7621/base-files/etc/board.d/01_leds
index 9e67d458de..5322bc9db0 100644
--- a/target/linux/ramips/mt7621/base-files/etc/board.d/01_leds
+++ b/target/linux/ramips/mt7621/base-files/etc/board.d/01_leds
@@ -51,7 +51,8 @@ linksys,e5600)
;;
linksys,ea7300-v1|\
linksys,ea7300-v2|\
-linksys,ea7500-v2)
+linksys,ea7500-v2|\
+linksys,ea8100-v1)
ucidef_set_led_netdev "lan1" "lan1 link" "green:lan1" "lan1" "link"
ucidef_set_led_netdev "lan2" "lan2 link" "green:lan2" "lan2" "link"
ucidef_set_led_netdev "lan3" "lan3 link" "green:lan3" "lan3" "link"
diff --git a/target/linux/ramips/mt7621/base-files/etc/board.d/02_network b/target/linux/ramips/mt7621/base-files/etc/board.d/02_network
index b31c99e6f1..d84d3e317f 100644
--- a/target/linux/ramips/mt7621/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/mt7621/base-files/etc/board.d/02_network
@@ -141,7 +141,8 @@ ramips_setup_macs()
linksys,e5600|\
linksys,ea7300-v1|\
linksys,ea7300-v2|\
- linksys,ea7500-v2)
+ linksys,ea7500-v2|\
+ linksys,ea8100-v1)
lan_mac=$(mtd_get_mac_ascii devinfo hw_mac_addr)
wan_mac=$lan_mac
label_mac=$lan_mac
diff --git a/target/linux/ramips/mt7621/base-files/etc/hotplug.d/ieee80211/10_fix_wifi_mac b/target/linux/ramips/mt7621/base-files/etc/hotplug.d/ieee80211/10_fix_wifi_mac
index 49b7f23ce9..bd0f0254c6 100644
--- a/target/linux/ramips/mt7621/base-files/etc/hotplug.d/ieee80211/10_fix_wifi_mac
+++ b/target/linux/ramips/mt7621/base-files/etc/hotplug.d/ieee80211/10_fix_wifi_mac
@@ -21,7 +21,8 @@ case "$board" in
linksys,e5600|\
linksys,ea7300-v1|\
linksys,ea7300-v2|\
- linksys,ea7500-v2)
+ linksys,ea7500-v2|\
+ linksys,ea8100-v1)
hw_mac_addr=$(mtd_get_mac_ascii devinfo hw_mac_addr)
[ "$PHYNBR" = "0" ] && macaddr_add $hw_mac_addr 1 > /sys${DEVPATH}/macaddress
[ "$PHYNBR" = "1" ] && macaddr_add $hw_mac_addr 2 > /sys${DEVPATH}/macaddress
diff --git a/target/linux/ramips/mt7621/base-files/etc/init.d/bootcount b/target/linux/ramips/mt7621/base-files/etc/init.d/bootcount
index cfaa62485c..d3525ea0c9 100755
--- a/target/linux/ramips/mt7621/base-files/etc/init.d/bootcount
+++ b/target/linux/ramips/mt7621/base-files/etc/init.d/bootcount
@@ -11,7 +11,8 @@ boot() {
linksys,e5600|\
linksys,ea7300-v1|\
linksys,ea7300-v2|\
- linksys,ea7500-v2)
+ linksys,ea7500-v2|\
+ linksys,ea8100-v1)
mtd resetbc s_env || true
;;
samknows,whitebox-v8)
diff --git a/target/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh b/target/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh
index 689a0e51ae..4943ad1305 100755
--- a/target/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh
@@ -62,6 +62,7 @@ platform_do_upgrade() {
linksys,ea7300-v1|\
linksys,ea7300-v2|\
linksys,ea7500-v2|\
+ linksys,ea8100-v1|\
netgear,r6220|\
netgear,r6260|\
netgear,r6350|\