summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2017-01-15 20:45:14 +0100
committerJohn Crispin <john@phrozen.org>2017-01-15 20:45:59 +0100
commitc067011af899bf637215849948a962241a3ed62a (patch)
tree7b1afc3aea70cc5ac13bc28772b30f782550e872 /target
parentf4f2dd04bd0bfeae99492683ecaa8fcabb9567a0 (diff)
downloadopenwrt-c067011af899bf637215849948a962241a3ed62a.tar.gz
openwrt-c067011af899bf637215849948a962241a3ed62a.tar.bz2
openwrt-c067011af899bf637215849948a962241a3ed62a.zip
ramips: add back the i2c-mt7621 module
mt7628/88 are still using this module. Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ramips/modules.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/ramips/modules.mk b/target/linux/ramips/modules.mk
index c2b6f50624..2bece6fc5c 100644
--- a/target/linux/ramips/modules.mk
+++ b/target/linux/ramips/modules.mk
@@ -58,6 +58,22 @@ endef
$(eval $(call KernelPackage,i2c-ralink))
+I2C_MT7621_MODULES:= \
+ CONFIG_I2C_MT7621:drivers/i2c/busses/i2c-mt7621
+
+define KernelPackage/i2c-mt7628
+ $(call i2c_defaults,$(I2C_MT7621_MODULES),59)
+ TITLE:=MT7628/88 I2C Controller
+ DEPENDS:=kmod-i2c-core \
+ @(TARGET_ramips_mt7628||TARGET_ramips_mt7688)
+endef
+
+define KernelPackage/i2c-mt7628/description
+ Kernel modules for enable mt7621 i2c controller.
+endef
+
+$(eval $(call KernelPackage,i2c-mt7628))
+
define KernelPackage/dma-ralink
SUBMENU:=Other modules
TITLE:=Ralink GDMA Engine