summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorLinus Walleij <linus.walleij@linaro.org>2024-05-21 09:30:28 +0200
committerLinus Walleij <linus.walleij@linaro.org>2024-05-25 09:17:19 +0200
commite7661a808e87753f47cea02312c85389f323ddf7 (patch)
treeaf99f9211eee3a6ad65f3a8592fb338c017c9573 /target
parent869bbdb8f68cb22096c78f38eac2f15081574199 (diff)
downloadopenwrt-e7661a808e87753f47cea02312c85389f323ddf7.tar.gz
openwrt-e7661a808e87753f47cea02312c85389f323ddf7.tar.bz2
openwrt-e7661a808e87753f47cea02312c85389f323ddf7.zip
ixp4xx: Add back support for D-Link DSM G600 A
OpenWrt supported the D-Link DSM G600 A in the past. It has 64 MB of RAM and 16 MB of flash so it will run just fine, and should be quite usable with a rootfs on an external harddrive. Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ixp4xx/base-files/etc/board.d/02_network1
-rw-r--r--target/linux/ixp4xx/image/Makefile12
2 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/ixp4xx/base-files/etc/board.d/02_network b/target/linux/ixp4xx/base-files/etc/board.d/02_network
index 7f75a2e20d..6a361d4f53 100644
--- a/target/linux/ixp4xx/base-files/etc/board.d/02_network
+++ b/target/linux/ixp4xx/base-files/etc/board.d/02_network
@@ -9,6 +9,7 @@ gateworks,gw2348|\
gateworks,gw2358)
ucidef_set_interfaces_lan_wan "eth0" "eth1"
;;
+dlink,dsm-g600-a|\
iom,nas-100d|\
linksys,nslu2)
ucidef_set_interface_lan "eth0" "dhcp"
diff --git a/target/linux/ixp4xx/image/Makefile b/target/linux/ixp4xx/image/Makefile
index 15f40821eb..ace533e50f 100644
--- a/target/linux/ixp4xx/image/Makefile
+++ b/target/linux/ixp4xx/image/Makefile
@@ -46,6 +46,18 @@ define Device/Default
BLOCKSIZE := 128k
endef
+define Device/dlink_dsm_g600_a
+ DEVICE_VENDOR := D-Link
+ DEVICE_MODEL := DSM G600 A
+ DEVICE_PACKAGES := ixp4xx-microcode-ethernet kmod-rtc-pcf8563 kmod-via-velocity kmod-ata-artop kmod-ath5k wpad-basic-mbedtls
+ DEVICE_DTS := intel-ixp42x-dlink-dsm-g600
+ KERNEL := kernel-bin | append-dtb
+ IMAGES := kernel.bin rootfs.bin
+ IMAGE/kernel.bin := append-kernel
+ IMAGE/rootfs.bin := append-rootfs | pad-rootfs | pad-to 128k
+endef
+TARGET_DEVICES += dlink_dsm_g600_a
+
define Device/freecom_fsg_3
DEVICE_VENDOR := Freecom
DEVICE_MODEL := FSG-3