summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorMoritz Warning <moritzwarning@web.de>2019-09-26 00:13:13 +0200
committerAlexander Couzens <lynxis@fe80.eu>2019-10-12 01:22:46 +0200
commitf3c21d1517b2139755a18536f5c655b4d48c8ca1 (patch)
treec05b7c642978b4de05ea6254acbd8c5076adf036 /target
parent36c6f4a011eeabf73a4a70da7796c565a27caf91 (diff)
downloadopenwrt-f3c21d1517b2139755a18536f5c655b4d48c8ca1.tar.gz
openwrt-f3c21d1517b2139755a18536f5c655b4d48c8ca1.tar.bz2
openwrt-f3c21d1517b2139755a18536f5c655b4d48c8ca1.zip
omap: split up DEVICE_TITLE
DEVICE_TITLE is split up into DEVICE_VENDOR, DEVICE_MODEL and DEVICE_VARIANT Signed-off-by: Moritz Warning <moritzwarning@web.de>
Diffstat (limited to 'target')
-rw-r--r--target/linux/omap/image/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/target/linux/omap/image/Makefile b/target/linux/omap/image/Makefile
index c7271aba8f..ce3ad9ddf0 100644
--- a/target/linux/omap/image/Makefile
+++ b/target/linux/omap/image/Makefile
@@ -44,21 +44,24 @@ endef
#uboot-omap-am335x_evm uboot-omap-omap3_beagle uboot-omap-omap3_overo uboot-omap-omap4_panda
define Device/ti_am335x-evm
- DEVICE_TITLE := TI AM335x EVM
+ DEVICE_VENDOR := Texas Instruments
+ DEVICE_MODEL := AM335x EVM
DEVICE_DTS := am335x-evm
endef
TARGET_DEVICES += ti_am335x-evm
define Device/ti_am335x-bone-black
- DEVICE_TITLE := TI AM335x BeagleBone Black
+ DEVICE_VENDOR := Texas Instruments
+ DEVICE_MODEL := AM335x BeagleBone Black
DEVICE_DTS := am335x-boneblack
endef
TARGET_DEVICES += ti_am335x-bone-black
define Device/ti_omap4-panda
- DEVICE_TITLE := OMAP4 TI pandaboard
+ DEVICE_VENDOR := PandaBoard.org
+ DEVICE_MODEL := OMAP4 TI pandaboard
DEVICE_DTS := omap4-panda
DEVICE_PACKAGES := kmod-usb-net-smsc95xx
endef
@@ -66,7 +69,8 @@ endef
TARGET_DEVICES += ti_omap4-panda
define Device/ti_omap3-beagle
- DEVICE_TITLE := OMAP3 TI beagleboard
+ DEVICE_VENDOR := BeagleBoard.org
+ DEVICE_MODEL := OMAP3 TI beagleboard
DEVICE_DTS := omap3-beagle
# beagleboard doesn't have a network interface, support most common usb net
DEVICE_PACKAGES := kmod-usb-net \