summaryrefslogtreecommitdiffstats
path: root/toolchain/gcc
diff options
context:
space:
mode:
authorThomas Weißschuh <thomas@t-8ch.de>2024-08-01 17:59:42 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2024-08-13 00:30:29 +0200
commit30092019fe6249d9cded6a27e6ceb24e82fbbb52 (patch)
treed3bcde06f794f6142ac42e01136226fcc8724e87 /toolchain/gcc
parente80520197c9ca7bced50d3605d6baba6dead6e35 (diff)
downloadopenwrt-30092019fe6249d9cded6a27e6ceb24e82fbbb52.tar.gz
openwrt-30092019fe6249d9cded6a27e6ceb24e82fbbb52.tar.bz2
openwrt-30092019fe6249d9cded6a27e6ceb24e82fbbb52.zip
toolchain: gcc: update GCC 14 to 14.2.0
All patches automatically rebased. Signed-off-by: Thomas Weißschuh <thomas@t-8ch.de> Link: https://github.com/openwrt/openwrt/pull/16047 Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/Config.version2
-rw-r--r--toolchain/gcc/common.mk4
-rw-r--r--toolchain/gcc/patches-14.x/300-mips_Os_cpu_rtx_cost_model.patch2
3 files changed, 4 insertions, 4 deletions
diff --git a/toolchain/gcc/Config.version b/toolchain/gcc/Config.version
index dc2ff9bff0..49bb36865e 100644
--- a/toolchain/gcc/Config.version
+++ b/toolchain/gcc/Config.version
@@ -15,7 +15,7 @@ config GCC_VERSION
default EXTERNAL_GCC_VERSION if EXTERNAL_TOOLCHAIN && !NATIVE_TOOLCHAIN
default "11.3.0" if GCC_VERSION_11
default "12.3.0" if GCC_VERSION_12
- default "14.1.0" if GCC_VERSION_14
+ default "14.2.0" if GCC_VERSION_14
default "13.3.0"
config GCC_USE_DEFAULT_VERSION
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index 2161ce72e4..0ccf55bd31 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -42,8 +42,8 @@ ifeq ($(PKG_VERSION),13.3.0)
PKG_HASH:=0845e9621c9543a13f484e94584a49ffc0129970e9914624235fc1d061a0c083
endif
-ifeq ($(PKG_VERSION),14.1.0)
- PKG_HASH:=e283c654987afe3de9d8080bc0bd79534b5ca0d681a73a11ff2b5d3767426840
+ifeq ($(PKG_VERSION),14.2.0)
+ PKG_HASH:=a7b39bc69cbf9e25826c5a60ab26477001f7c08d85cec04bc0e29cabed6f3cc9
endif
PATCH_DIR=../patches-$(GCC_MAJOR_VERSION).x
diff --git a/toolchain/gcc/patches-14.x/300-mips_Os_cpu_rtx_cost_model.patch b/toolchain/gcc/patches-14.x/300-mips_Os_cpu_rtx_cost_model.patch
index 2d65ba1b1f..2cbffe4517 100644
--- a/toolchain/gcc/patches-14.x/300-mips_Os_cpu_rtx_cost_model.patch
+++ b/toolchain/gcc/patches-14.x/300-mips_Os_cpu_rtx_cost_model.patch
@@ -10,7 +10,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
--- a/gcc/config/mips/mips.cc
+++ b/gcc/config/mips/mips.cc
-@@ -20444,7 +20444,7 @@ mips_option_override (void)
+@@ -20453,7 +20453,7 @@ mips_option_override (void)
flag_pcc_struct_return = 0;
/* Decide which rtx_costs structure to use. */