summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2023-12-19 10:53:41 +0100
committerFelix Fietkau <nbd@nbd.name>2023-12-19 10:54:19 +0100
commit2872ff7be19cfd20c95c4cbc880c0af38f82ea15 (patch)
treefbcf7efc201670ee537ed887f0982332dd2450b3 /toolchain
parent6d546b3b4cdae3ffcdad71fb6cc414f3a39bc09e (diff)
downloadopenwrt-2872ff7be19cfd20c95c4cbc880c0af38f82ea15.tar.gz
openwrt-2872ff7be19cfd20c95c4cbc880c0af38f82ea15.tar.bz2
openwrt-2872ff7be19cfd20c95c4cbc880c0af38f82ea15.zip
toolchain/gdb: add pthread to CFLAGS/LDFLAGS for zstd
Works around a build issue when building on a host with an older glibc, where it would fail to detect ELF support in libbfd Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gdb/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/toolchain/gdb/Makefile b/toolchain/gdb/Makefile
index 5ad0cd2d8c..ecb31398e6 100644
--- a/toolchain/gdb/Makefile
+++ b/toolchain/gdb/Makefile
@@ -22,8 +22,8 @@ HOST_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/toolchain-build.mk
-export ZSTD_CFLAGS=-I$(STAGING_DIR_HOST)/include
-export ZSTD_LIBS=-L$(STAGING_DIR_HOST)/lib -lzstd
+export ZSTD_CFLAGS=-I$(STAGING_DIR_HOST)/include -pthread
+export ZSTD_LIBS=-L$(STAGING_DIR_HOST)/lib -lzstd -lpthread
HOST_CONFIGURE_VARS += \
acx_cv_cc_gcc_supports_ada=false \