summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorIvan Maslov <avenger_msoft@mail.ru>2022-01-29 23:11:30 +0300
committerChristian Marangi <ansuelsmth@gmail.com>2022-07-07 13:55:32 +0200
commit3c06a344e9c7c03c49c9153342e68a5390651323 (patch)
treeb60d7b2e04db8de43a43292beebbc1a05ec39313 /toolchain
parent9b00e9795660f53caf1f4f5fd932bbbebd2eeeb1 (diff)
downloadopenwrt-3c06a344e9c7c03c49c9153342e68a5390651323.tar.gz
openwrt-3c06a344e9c7c03c49c9153342e68a5390651323.tar.bz2
openwrt-3c06a344e9c7c03c49c9153342e68a5390651323.zip
toolchaini/gcc: fix libstdc++ dual abi model
libstdcxx-dual-abi needs to be enabled to actually support C++11 ABI. Enable the config flag to also permit support of .NET 6 development on OpenWrt. Signed-off-by: Ivan Maslov <avenger_msoft@mail.ru> [ reword commit description and title ] Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/common.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index 8fa9459f50..926418f4a7 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -119,7 +119,7 @@ GCC_CONFIGURE:= \
--disable-decimal-float \
--with-diagnostics-color=auto-if-env \
--enable-__cxa_atexit \
- --disable-libstdcxx-dual-abi \
+ --enable-libstdcxx-dual-abi \
--with-default-libstdcxx-abi=new
ifneq ($(CONFIG_mips)$(CONFIG_mipsel),)
GCC_CONFIGURE += --with-mips-plt