summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorOlcay Korkmaz <nuke_mania@hotmail.com>2024-09-17 00:28:21 +0300
committerRobert Marko <robimarko@gmail.com>2024-09-17 11:30:26 +0200
commit802be2457f41cebcf8a48b90d26d609009328294 (patch)
tree83d128ef392a8fe771b8e3c8ad1618021e50c805 /toolchain
parent7e1d0925526a104364630b7af5355b799ef884d9 (diff)
downloadopenwrt-802be2457f41cebcf8a48b90d26d609009328294.tar.gz
openwrt-802be2457f41cebcf8a48b90d26d609009328294.tar.bz2
openwrt-802be2457f41cebcf8a48b90d26d609009328294.zip
toolchain: binutils: add support for 2.43.1
Release notes: https://lists.gnu.org/archive/html/info-gnu/2024-08/msg00003.html No need to refresh patches Test device: Xiaomi ax3600 Signed-off-by: Olcay Korkmaz <nuke_mania@hotmail.com> Link: https://github.com/openwrt/openwrt/pull/16405 Signed-off-by: Robert Marko <robimarko@gmail.com>
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/binutils/Config.in2
-rw-r--r--toolchain/binutils/Config.version2
-rw-r--r--toolchain/binutils/Makefile4
-rw-r--r--toolchain/binutils/patches/2.43.1/300-001_ld_makefile_patch.patch (renamed from toolchain/binutils/patches/2.43/300-001_ld_makefile_patch.patch)0
-rw-r--r--toolchain/binutils/patches/2.43.1/400-mips_no_dynamic_linking_sym.patch (renamed from toolchain/binutils/patches/2.43/400-mips_no_dynamic_linking_sym.patch)0
-rw-r--r--toolchain/binutils/patches/2.43.1/500-Change-default-emulation-for-mips64-linux.patch (renamed from toolchain/binutils/patches/2.43/500-Change-default-emulation-for-mips64-linux.patch)0
6 files changed, 4 insertions, 4 deletions
diff --git a/toolchain/binutils/Config.in b/toolchain/binutils/Config.in
index 3e3a2b5509..93ef5d82c8 100644
--- a/toolchain/binutils/Config.in
+++ b/toolchain/binutils/Config.in
@@ -31,7 +31,7 @@ choice
select BINUTILS_VERSION_2_42
config BINUTILS_USE_VERSION_2_43
- bool "Binutils 2.43"
+ bool "Binutils 2.43.1"
select BINUTILS_VERSION_2_43
endchoice
diff --git a/toolchain/binutils/Config.version b/toolchain/binutils/Config.version
index b2bf7f7d00..98605f469a 100644
--- a/toolchain/binutils/Config.version
+++ b/toolchain/binutils/Config.version
@@ -29,4 +29,4 @@ config BINUTILS_VERSION
default "2.40" if BINUTILS_VERSION_2_40
default "2.41" if BINUTILS_VERSION_2_41
default "2.42" if BINUTILS_VERSION_2_42
- default "2.43" if BINUTILS_VERSION_2_43
+ default "2.43.1" if BINUTILS_VERSION_2_43
diff --git a/toolchain/binutils/Makefile b/toolchain/binutils/Makefile
index 1db64d058c..92ec8ec7e3 100644
--- a/toolchain/binutils/Makefile
+++ b/toolchain/binutils/Makefile
@@ -40,8 +40,8 @@ ifeq ($(PKG_VERSION),2.42)
PKG_HASH:=f6e4d41fd5fc778b06b7891457b3620da5ecea1006c6a4a41ae998109f85a800
endif
-ifeq ($(PKG_VERSION),2.43)
- PKG_HASH:=b53606f443ac8f01d1d5fc9c39497f2af322d99e14cea5c0b4b124d630379365
+ifeq ($(PKG_VERSION),2.43.1)
+ PKG_HASH:=13f74202a3c4c51118b797a39ea4200d3f6cfbe224da6d1d95bb938480132dfd
endif
HOST_BUILD_PARALLEL:=1
diff --git a/toolchain/binutils/patches/2.43/300-001_ld_makefile_patch.patch b/toolchain/binutils/patches/2.43.1/300-001_ld_makefile_patch.patch
index 64dae55dd7..64dae55dd7 100644
--- a/toolchain/binutils/patches/2.43/300-001_ld_makefile_patch.patch
+++ b/toolchain/binutils/patches/2.43.1/300-001_ld_makefile_patch.patch
diff --git a/toolchain/binutils/patches/2.43/400-mips_no_dynamic_linking_sym.patch b/toolchain/binutils/patches/2.43.1/400-mips_no_dynamic_linking_sym.patch
index d0cc7ddc69..d0cc7ddc69 100644
--- a/toolchain/binutils/patches/2.43/400-mips_no_dynamic_linking_sym.patch
+++ b/toolchain/binutils/patches/2.43.1/400-mips_no_dynamic_linking_sym.patch
diff --git a/toolchain/binutils/patches/2.43/500-Change-default-emulation-for-mips64-linux.patch b/toolchain/binutils/patches/2.43.1/500-Change-default-emulation-for-mips64-linux.patch
index df38fcaba1..df38fcaba1 100644
--- a/toolchain/binutils/patches/2.43/500-Change-default-emulation-for-mips64-linux.patch
+++ b/toolchain/binutils/patches/2.43.1/500-Change-default-emulation-for-mips64-linux.patch