summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2008-07-14 23:24:58 +0000
committerNicolas Thill <nico@openwrt.org>2008-07-14 23:24:58 +0000
commit89eb716470a2262ccb855d7402711b940805ef20 (patch)
tree4f94fe05b3183dbc83fc7c9c2b42f9a08d7edfab /toolchain
parent3890bd2126a29b85aabbda3fc4311736640ff5fa (diff)
downloadopenwrt-89eb716470a2262ccb855d7402711b940805ef20.tar.gz
openwrt-89eb716470a2262ccb855d7402711b940805ef20.tar.bz2
openwrt-89eb716470a2262ccb855d7402711b940805ef20.zip
use qstrip macro to strip quoted CONFIG_* strings
SVN-Revision: 11832
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/binutils/Makefile3
-rw-r--r--toolchain/gcc/Makefile2
-rw-r--r--toolchain/uClibc/Makefile6
3 files changed, 5 insertions, 6 deletions
diff --git a/toolchain/binutils/Makefile b/toolchain/binutils/Makefile
index 8682fa5969..1023d9e671 100644
--- a/toolchain/binutils/Makefile
+++ b/toolchain/binutils/Makefile
@@ -7,8 +7,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=binutils
-PKG_VERSION:=$(strip $(subst ",, $(CONFIG_BINUTILS_VERSION)))
-#"))
+PKG_VERSION:=$(call qstrip,$(CONFIG_BINUTILS_VERSION))
PKG_SOURCE_URL:=http://ftp.gnu.org/gnu/binutils/ \
ftp://gatekeeper.dec.com/pub/GNU/ \
diff --git a/toolchain/gcc/Makefile b/toolchain/gcc/Makefile
index ef5ab22d0f..31697989c9 100644
--- a/toolchain/gcc/Makefile
+++ b/toolchain/gcc/Makefile
@@ -21,7 +21,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=gcc
-PKG_VERSION:=$(strip $(subst ",, $(CONFIG_GCC_VERSION)))#"))
+PKG_VERSION:=$(call qstrip,$(CONFIG_GCC_VERSION))
PATCH_DIR=./patches/$(PKG_VERSION)
PKG_SOURCE_URL:=ftp://ftp.fu-berlin.de/unix/languages/gcc/releases/gcc-$(PKG_VERSION) \
diff --git a/toolchain/uClibc/Makefile b/toolchain/uClibc/Makefile
index e6f2b7b191..8c02489b14 100644
--- a/toolchain/uClibc/Makefile
+++ b/toolchain/uClibc/Makefile
@@ -8,9 +8,9 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/target.mk
PKG_NAME:=uClibc
-PKG_VERSION:=$(strip $(subst ",, $(CONFIG_UCLIBC_VERSION)))#"))
-PKG_EXTRAVERSION:=$(strip $(subst ",, $(CONFIG_UCLIBC_EXTRA_VERSION)))#"))
-PKG_VERSION_SNAPSHOT:=$(strip $(subst ",, $(CONFIG_UCLIBC_VERSION_SNAPSHOT)))#"))
+PKG_VERSION:=$(call qstrip,$(CONFIG_UCLIBC_VERSION))
+PKG_EXTRAVERSION:=$(call qstrip,$(CONFIG_UCLIBC_EXTRA_VERSION))
+PKG_VERSION_SNAPSHOT:=$(call qstrip,$(CONFIG_UCLIBC_VERSION_SNAPSHOT))
ifeq ($(PKG_VERSION_SNAPSHOT),y)
PKG_SOURCE_URL:=http://www.uclibc.org/downloads/snapshots
else