summaryrefslogtreecommitdiffstats
path: root/tools/7z
diff options
context:
space:
mode:
authorNick Hainke <vincent@systemli.org>2023-07-19 15:45:10 +0200
committerNick Hainke <vincent@systemli.org>2023-08-01 13:26:04 +0200
commit4ca450deaca133b14a7798ab1803129c3f26353a (patch)
treee58a462b5248e4d1c859893ffa6166cece38c041 /tools/7z
parent11bf820124e3155ef6b1762cd3ca533b9a7d577d (diff)
downloadopenwrt-4ca450deaca133b14a7798ab1803129c3f26353a.tar.gz
openwrt-4ca450deaca133b14a7798ab1803129c3f26353a.tar.bz2
openwrt-4ca450deaca133b14a7798ab1803129c3f26353a.zip
tools/7z: update to 23.01
Release Notes: https://sourceforge.net/p/sevenzip/discussion/45797/thread/3f550826d8/#e950 Manually adjust: - 7-zip-flags.patch Automatically refresh: - 7-zip-musl.patch Signed-off-by: Nick Hainke <vincent@systemli.org>
Diffstat (limited to 'tools/7z')
-rw-r--r--tools/7z/Makefile6
-rw-r--r--tools/7z/patches/7-zip-flags.patch15
-rw-r--r--tools/7z/patches/7-zip-musl.patch8
3 files changed, 11 insertions, 18 deletions
diff --git a/tools/7z/Makefile b/tools/7z/Makefile
index 90362e7977..351ae527ff 100644
--- a/tools/7z/Makefile
+++ b/tools/7z/Makefile
@@ -1,12 +1,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=7z
-PKG_VERSION:=22.01
-PKG_SOURCE_VERSION:=2201
+PKG_VERSION:=23.01
+PKG_SOURCE_VERSION:=2301
PKG_SOURCE:=$(PKG_NAME)$(PKG_SOURCE_VERSION)-src.tar.xz
PKG_SOURCE_URL:=https://7-zip.org/a/
-PKG_HASH:=393098730c70042392af808917e765945dc2437dee7aae3cfcc4966eb920fbc5
+PKG_HASH:=356071007360e5a1824d9904993e8b2480b51b570e8c9faf7c0f58ebe4bf9f74
# This builds the 7zr variant which supports only 7z, so no non-LGPL code should be included
PKG_LICENSE:=LGPL-2.1-or-later
diff --git a/tools/7z/patches/7-zip-flags.patch b/tools/7z/patches/7-zip-flags.patch
index ed5b508401..b9b2152f22 100644
--- a/tools/7z/patches/7-zip-flags.patch
+++ b/tools/7z/patches/7-zip-flags.patch
@@ -1,14 +1,16 @@
--- a/CPP/7zip/7zip_gcc.mak
+++ b/CPP/7zip/7zip_gcc.mak
-@@ -18,13 +18,13 @@ PROGPATH_STATIC = $(O)/$(PROG)s
+@@ -24,7 +24,7 @@ PROGPATH_STATIC = $(O)/$(PROG)s
ifneq ($(CC), xlc)
--CFLAGS_WARN_WALL = -Wall -Werror -Wextra
+-CFLAGS_WARN_WALL = -Werror -Wall -Wextra
+CFLAGS_WARN_WALL = -Wall -Wextra
endif
# for object file
+@@ -32,7 +32,7 @@ endif
+ # -save-temps
CFLAGS_BASE_LIST = -c
# CFLAGS_BASE_LIST = -S
-CFLAGS_BASE = -O2 $(CFLAGS_BASE_LIST) $(CFLAGS_WARN_WALL) $(CFLAGS_WARN) \
@@ -16,12 +18,3 @@
-DNDEBUG -D_REENTRANT -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE \
-fPIC
-@@ -192,7 +192,7 @@ all: $(O) $(PROGPATH) $(STATIC_TARGET)
- $(O):
- $(MY_MKDIR) $(O)
-
--LFLAGS_ALL = -s $(MY_ARCH_2) $(LDFLAGS) $(LD_arch) $(OBJS) $(MY_LIBS) $(LIB2)
-+LFLAGS_ALL = $(MY_ARCH_2) $(LDFLAGS) $(LD_arch) $(OBJS) $(MY_LIBS) $(LIB2)
- $(PROGPATH): $(OBJS)
- $(CXX) -o $(PROGPATH) $(LFLAGS_ALL)
-
diff --git a/tools/7z/patches/7-zip-musl.patch b/tools/7z/patches/7-zip-musl.patch
index cf3386e4de..e066cc8ec9 100644
--- a/tools/7z/patches/7-zip-musl.patch
+++ b/tools/7z/patches/7-zip-musl.patch
@@ -1,6 +1,6 @@
--- a/C/CpuArch.c
+++ b/C/CpuArch.c
-@@ -421,8 +421,6 @@ BoolInt CPU_IsSupported_AES (void) { ret
+@@ -766,8 +766,6 @@ BoolInt CPU_IsSupported_AES (void) { ret
#ifdef USE_HWCAP
@@ -11,7 +11,7 @@
--- a/C/Threads.c
+++ b/C/Threads.c
-@@ -257,7 +257,7 @@ WRes Thread_Create_With_CpuSet(CThread *
+@@ -265,7 +265,7 @@ WRes Thread_Create_With_CpuSet(CThread *
*/
// ret2 =
@@ -20,7 +20,7 @@
// if (ret2) ret = ret2;
#endif
}
-@@ -267,14 +267,12 @@ WRes Thread_Create_With_CpuSet(CThread *
+@@ -275,14 +275,12 @@ WRes Thread_Create_With_CpuSet(CThread *
if (!ret)
{
p->_created = 1;
@@ -37,7 +37,7 @@
// ret2 =
--- a/C/Threads.h
+++ b/C/Threads.h
-@@ -19,6 +19,7 @@
+@@ -20,6 +20,7 @@
#endif
#include <pthread.h>