summaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorMichael Pratt <mcpratt@pm.me>2023-03-23 03:49:01 -0400
committerChristian Marangi <ansuelsmth@gmail.com>2023-05-04 06:07:30 +0200
commit09f8f21ae33402201c14a125a37b64746415642d (patch)
treecd53d8bfdd5a9bae8c865aa62b2bde2408f1bc15 /tools/Makefile
parent87e902fcdcce0e3d1287deb901f934aabf7ec183 (diff)
downloadopenwrt-09f8f21ae33402201c14a125a37b64746415642d.tar.gz
openwrt-09f8f21ae33402201c14a125a37b64746415642d.tar.bz2
openwrt-09f8f21ae33402201c14a125a37b64746415642d.zip
tools/coreutils: bootstrap to local gnulib source
Using the local gnulib source during bootstrap allows for fine-grained control over the macros and source files for use with coreutils but part of gnulib instead of coreutils, without having to wait for a release or deal with gnulib as a git submodule. In this case, the execution of autotools must be skipped by force. Autoconf and Automake during bootstrap on coreutils only works right when using directly checked-out source. There is a symbol in gnulib, @GNULIB_TIME@ that is not yet defined in coreutils source, so we use the backup of lib/time.in.h instead of the one provided by gnulib source. Signed-off-by: Michael Pratt <mcpratt@pm.me>
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 3f12828a8f..40c3ec1ab0 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -127,6 +127,7 @@ $(curdir)/squashfs4/compile := $(curdir)/xz/compile $(curdir)/zlib/compile
$(curdir)/zstd/compile := $(curdir)/meson/compile
ifneq ($(HOST_OS),Linux)
+ $(curdir)/coreutils/compile += $(curdir)/automake/compile $(curdir)/bison/compile $(curdir)/gnulib/compile
$(curdir)/squashfs4/compile += $(curdir)/coreutils/compile
tools-y += coreutils
endif