summaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2021-11-04 19:05:16 +0100
committerFelix Fietkau <nbd@nbd.name>2021-11-04 19:05:17 +0100
commit10cbce3b52c9a21b115a471fa548a40e1212e3e9 (patch)
treedb762b53a6b789589365a303cd4d9ac4f0f07bb1 /tools/Makefile
parent2a832b3df5990f33aa3d5944733e43bf5287475c (diff)
downloadopenwrt-10cbce3b52c9a21b115a471fa548a40e1212e3e9.tar.gz
openwrt-10cbce3b52c9a21b115a471fa548a40e1212e3e9.tar.bz2
openwrt-10cbce3b52c9a21b115a471fa548a40e1212e3e9.zip
tools: ensure that BIN_DIR is created early
Fixes llvm-bpf buildbot failure Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/tools/Makefile b/tools/Makefile
index ad8eeb31a4..686d5294d3 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -125,6 +125,9 @@ define PrepareStaging
); done
endef
+$(BIN_DIR):
+ mkdir -p $@
+
# preparatory work
$(STAGING_DIR)/.prepared: $(TMP_DIR)/.build
$(call PrepareStaging,$(STAGING_DIR))
@@ -145,8 +148,8 @@ endif
endif
-$(curdir)//prepare = $(STAGING_DIR)/.prepared $(STAGING_DIR_HOST)/.prepared
-$(curdir)//compile = $(STAGING_DIR)/.prepared $(STAGING_DIR_HOST)/.prepared
+$(curdir)//prepare = $(STAGING_DIR)/.prepared $(STAGING_DIR_HOST)/.prepared $(BIN_DIR)
+$(curdir)//compile = $(STAGING_DIR)/.prepared $(STAGING_DIR_HOST)/.prepared $(BIN_DIR)
# prerequisites for the individual targets
$(curdir)/ := .config prereq