summaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2022-01-27 13:25:39 +0100
committerFelix Fietkau <nbd@nbd.name>2022-01-27 13:38:48 +0100
commit3869ccbcc891a7185550a2a422e2db01fd994b7d (patch)
tree7614324a1ba80c8ac421cb964ca8b3c5a275346c /tools/Makefile
parent1d4750fd50eeadad640fb62e1b11bf4cdde39dd1 (diff)
downloadopenwrt-3869ccbcc891a7185550a2a422e2db01fd994b7d.tar.gz
openwrt-3869ccbcc891a7185550a2a422e2db01fd994b7d.tar.bz2
openwrt-3869ccbcc891a7185550a2a422e2db01fd994b7d.zip
tools: build bash on macOS and use it for ipkg-build
On macOS, system binaries silently drop the environment variables for injecting extra shared libraries (used by fakeroot). This is done for security reasons. Work around this by building bash from source, so that it gets an ad-hoc signature and does not have these restrictions Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 686d5294d3..681344a014 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -80,6 +80,9 @@ ifneq ($(HOST_OS),Linux)
$(curdir)/squashfskit4/compile += $(curdir)/coreutils/compile
tools-y += coreutils
endif
+ifeq ($(HOST_OS),Darwin)
+ tools-y += bash
+endif
ifneq ($(CONFIG_CCACHE)$(CONFIG_SDK),)
$(foreach tool, $(filter-out xz zstd pkgconf patch ninja meson libressl cmake,$(tools-y)), $(eval $(curdir)/$(tool)/compile += $(curdir)/ccache/compile))