summaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorTony Butler <spudz76@gmail.com>2022-11-30 06:19:37 -0800
committerChristian Marangi <ansuelsmth@gmail.com>2023-04-18 13:57:47 +0200
commit394d7134ec42f14ddb91769c737098753fa68266 (patch)
tree3281d3943c1b213382cca41532c54f3bcafee4d2 /tools/Makefile
parent5264296ce480e46c7cd6228502b48ea944a6459b (diff)
downloadopenwrt-394d7134ec42f14ddb91769c737098753fa68266.tar.gz
openwrt-394d7134ec42f14ddb91769c737098753fa68266.tar.bz2
openwrt-394d7134ec42f14ddb91769c737098753fa68266.zip
tools/bzip2: add `bzip2` binaries
`bzip2` is the standard executable for bzip2 compression this includes development includes and both static and shared libs (libbz2) which can be used by other packages the initramfs generator offers the BZIP2 option but there was no executable to support it, and worked only via side effect of having a system-installed version of bzip2, which could be less predictable Signed-off-by: Tony Butler <spudz76@gmail.com>
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/tools/Makefile b/tools/Makefile
index bdd9f0a257..251ca2c460 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -20,6 +20,9 @@ endif
ifneq ($(CONFIG_SDK)$(CONFIG_PACKAGE_kmod-b43)$(CONFIG_BRCMSMAC_USE_FW_FROM_WL),)
BUILD_B43_TOOLS = y
endif
+ifneq ($(CONFIG_SDK)$(CONFIG_TARGET_INITRAMFS_COMPRESSION_BZIP2),)
+ BUILD_BZIP2_TOOLS = y
+endif
ifneq ($(CONFIG_SDK)$(CONFIG_TARGET_INITRAMFS_COMPRESSION_LZ4),)
BUILD_LZ4_TOOLS = y
endif
@@ -64,8 +67,8 @@ tools-y += sstrip
tools-y += zip
tools-y += zlib
tools-y += zstd
-tools-$(if $(CONFIG_BUILD_ALL_HOST_TOOLS),y) += liblzo
tools-$(if $(CONFIG_BUILD_ALL_HOST_TOOLS)$(BUILD_B43_TOOLS),y) += b43-tools
+tools-$(if $(CONFIG_BUILD_ALL_HOST_TOOLS)$(BUILD_BZIP2_TOOLS),y) += bzip2
tools-$(if $(CONFIG_BUILD_ALL_HOST_TOOLS)$(BUILD_ISL),y) += isl
tools-$(if $(CONFIG_BUILD_ALL_HOST_TOOLS)$(BUILD_LZ4_TOOLS),y) += lz4
tools-$(if $(CONFIG_BUILD_ALL_HOST_TOOLS)$(BUILD_LZO_TOOLS),y) += lzop