summaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2023-01-11 18:41:22 +0100
committerFelix Fietkau <nbd@nbd.name>2023-10-29 15:56:46 +0100
commit5331e85d96346be4200ce206b2f4373e23af0f6f (patch)
treee1a4287a6e836c11b13be8fbbd739561be3929c1 /tools/Makefile
parent169757c7fd483787fb910c9d7b366fcd91ead49f (diff)
downloadopenwrt-5331e85d96346be4200ce206b2f4373e23af0f6f.tar.gz
openwrt-5331e85d96346be4200ce206b2f4373e23af0f6f.tar.bz2
openwrt-5331e85d96346be4200ce206b2f4373e23af0f6f.zip
elfutils: fix build and enable on non-linux systems
Use gnulib for compatibility Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/tools/Makefile b/tools/Makefile
index bf525d34a0..3a00dcc218 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -39,6 +39,7 @@ tools-y += cmake
tools-y += cpio
tools-y += dosfstools
tools-y += e2fsprogs
+tools-y += elfutils
tools-y += expat
tools-y += fakeroot
tools-y += findutils
@@ -95,6 +96,7 @@ $(curdir)/cbootimage/compile += $(curdir)/automake/compile
$(curdir)/cmake/compile += $(curdir)/libressl/compile $(curdir)/ninja/compile $(curdir)/expat/compile $(curdir)/xz/compile $(curdir)/zlib/compile $(curdir)/zstd/compile
$(curdir)/dosfstools/compile := $(curdir)/automake/compile
$(curdir)/e2fsprogs/compile := $(curdir)/libtool/compile
+$(curdir)/elfutils/compile := $(curdir)/m4/compile $(curdir)/zlib/compile $(curdir)/gnulib/compile
$(curdir)/fakeroot/compile := $(curdir)/libtool/compile
$(curdir)/findutils/compile := $(curdir)/bison/compile
$(curdir)/firmware-utils/compile += $(curdir)/cmake/compile
@@ -137,9 +139,7 @@ ifeq ($(HOST_OS),Darwin)
tools-y += bash
else
$(curdir)/dwarves/compile += $(curdir)/elfutils/compile
- $(curdir)/elfutils/compile := $(curdir)/m4/compile $(curdir)/zlib/compile
tools-$(if $(CONFIG_BUILD_ALL_HOST_TOOLS)$(CONFIG_DWARVES),y) += dwarves
- tools-y += elfutils
endif
ifneq ($(CONFIG_CCACHE)$(CONFIG_SDK),)