summaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorOlliver Schinagl <oliver@schinagl.nl>2023-01-17 20:54:05 +0100
committerOlliver Schinagl <oliver@schinagl.nl>2023-01-17 20:54:05 +0100
commit92feae64eb8d3a315fb0aa311b3fac9818a51505 (patch)
tree951b1e4573995ece2a1c13ab56089394f7bb9ab5 /tools/Makefile
parent4a444e576fd26764ed11aed8c3bdf2281bba3cc6 (diff)
downloadopenwrt-92feae64eb8d3a315fb0aa311b3fac9818a51505.tar.gz
openwrt-92feae64eb8d3a315fb0aa311b3fac9818a51505.tar.bz2
openwrt-92feae64eb8d3a315fb0aa311b3fac9818a51505.zip
tools: Improve diffability/maintainability
Like with commit ae614fb397c2 ("tools: Improve diffability/maintainability") we also want tools-core to be easy to maintain. While a smaller target, it's still usefull and makes things nice and consistent. To avoid duplicating any tools in the comment, simplify the comment instead. Signed-off-by: Olliver Schinagl <oliver@schinagl.nl>
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/tools/Makefile b/tools/Makefile
index a8044dcf1f..7ca874aa91 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -147,8 +147,10 @@ $(foreach tool, $(tools-y), $(if $(wildcard $(curdir)/$(tool)/patches),$(eval $(
$(foreach tool, $(filter-out xz,$(tools-y)), $(eval $(curdir)/$(tool)/compile += $(curdir)/xz/compile))
-# make any tool depend on tar, xz and patch to ensure that archives can be unpacked and patched properly
-tools-core := tar xz patch
+# make any tool depend on the following to ensure that archives can be unpacked and patched properly
+tools-core += patch
+tools-core += tar
+tools-core += xz
$(foreach tool, $(tools-y), $(eval $(curdir)/$(tool)/compile += $(patsubst %,$(curdir)/%/compile,$(tools-core))))
tools-y += $(tools-core)