summaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2022-09-25 00:22:24 -0700
committerChristian Marangi <ansuelsmth@gmail.com>2022-09-29 19:33:13 +0200
commitd602e7a969922121800e8f24d81cecdaab3aae75 (patch)
treeed2f0c7992c4d2722727f5fa15b0d9bce5a207c6 /tools/Makefile
parentec8fb542ec3e4f584444a97de5ac05dbc2a9cde5 (diff)
downloadopenwrt-d602e7a969922121800e8f24d81cecdaab3aae75.tar.gz
openwrt-d602e7a969922121800e8f24d81cecdaab3aae75.tar.bz2
openwrt-d602e7a969922121800e8f24d81cecdaab3aae75.zip
tools/zlib: switch to configure script
A future commit will make tools/cmake use this. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 5b7eaf8cd3..ae1c3ded85 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -75,7 +75,6 @@ $(curdir)/quilt/compile := $(curdir)/autoconf/compile $(curdir)/findutils/compil
$(curdir)/sdcc/compile := $(curdir)/bison/compile
$(curdir)/squashfs/compile := $(curdir)/lzma-old/compile
$(curdir)/squashfskit4/compile := $(curdir)/xz/compile $(curdir)/zlib/compile
-$(curdir)/zlib/compile := $(curdir)/cmake/compile
$(curdir)/zstd/compile := $(curdir)/meson/compile
ifneq ($(HOST_OS),Linux)
@@ -92,7 +91,7 @@ else
endif
ifneq ($(CONFIG_CCACHE)$(CONFIG_SDK),)
-$(foreach tool, $(filter-out xz zstd pkgconf patch ninja meson libressl cmake,$(tools-y)), $(eval $(curdir)/$(tool)/compile += $(curdir)/ccache/compile))
+$(foreach tool, $(filter-out zstd zlib xz pkgconf patch ninja meson libressl cmake,$(tools-y)), $(eval $(curdir)/$(tool)/compile += $(curdir)/ccache/compile))
tools-y += ccache
$(curdir)/ccache/compile := $(curdir)/cmake/compile $(curdir)/zstd/compile
endif