summaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2024-04-03 12:17:21 -0700
committerRobert Marko <robimarko@gmail.com>2024-04-06 11:24:18 +0200
commite09d3fd2904a35beaf5e27e81538cd8061b0ef36 (patch)
tree89e4e10e752c3b8fdfa94c8ef28d8c21192cadd5 /tools/Makefile
parentc3e43b7e654982f8f48ec63558806be2647da7e4 (diff)
downloadopenwrt-e09d3fd2904a35beaf5e27e81538cd8061b0ef36.tar.gz
openwrt-e09d3fd2904a35beaf5e27e81538cd8061b0ef36.tar.bz2
openwrt-e09d3fd2904a35beaf5e27e81538cd8061b0ef36.zip
tools: rework tools-core dependecies
ZSTD and libdeflate do not depend on SED nor flock, so instead of the whole for loop that will filter 2 out of 4 core packages just specify that patch and tar depend on sed explicitly. ZSTD now depends on libdeflate since libdeflate-gzip will then be used to unpack ZSTD as well as most tool archives. Signed-off-by: Rosen Penev <rosenp@gmail.com> Signed-off-by: Robert Marko <robimarko@gmail.com>
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 445101c012..f60a458f98 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -164,8 +164,10 @@ tools-core += zstd
$(foreach tool, $(tools-y), $(eval $(curdir)/$(tool)/compile += $(patsubst %,$(curdir)/%/compile,$(tools-core))))
tools-y += $(tools-core)
-# make core tools depend on sed and flock
-$(foreach tool, $(filter-out zstd,$(tools-core)), $(eval $(curdir)/$(tool)/compile += $(curdir)/sed/compile))
+# make some core tools depend on sed and flock
+$(curdir)/patch/compile += $(curdir)/sed/compile
+$(curdir)/tar/compile += $(curdir)/sed/compile
+$(curdir)/zstd/compile += $(curdir)/libdeflate/compile
$(curdir)/sed/compile := $(curdir)/flock/compile $(curdir)/zstd/compile
tools-y += flock sed